Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Modern Electronic Engines> slight misfire
User Name
Password
lost password?   |   register now

Thread: slight misfire Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-24-2011 08:43 AM
sbchevfreak On a Ford, OEM all the way. I have ran into problems with the quality consistency of aftermarket coils, especially where Ford is concerned for some reason.
12-22-2011 06:43 PM
LATECH I have used brands from advanced and it has been OK. Some of the chrysler ones seem to be problematic.Other than that (I think it is BWD) they seem OK.
I am anal about quality for my own and would get NAPA or Ford(OEM) for my own.The customers seem to want to get out cheaply, so advanced it is for them.Most of the time ,like I said, it works out.
If you have a decent scanner, you can look at the misfire monitors for all 8 cylinders and it should give a clear indication of which one is acting up.
Also it may set a pending code(1 trip code) for the offending cylinder, which may help ID the culprit
12-22-2011 06:23 PM
Tom P.
slight misfire

My 2003 Mustang GT has a slight misfire. When I'm driving along at about any speed, the engine will occasionally stumble. I had the plugs replaced, as well as one ignition coil. I suspect the other coils may be weak and need to be replaced. Any recommendations as to what brand of coils to use?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.