Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 1994 corvette hesitation
User Name
Password
lost password?   |   register now

Thread: 1994 corvette hesitation Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-25-2011 11:03 AM
7hr Reaperxx
those are still the factory parts. I regularly use fuel tank injector cleaners

I use the bottles of injector cleaner bout every 4th tank but they have never been out of the car to be cleaned. Discovered yesterday that the car runs perfect till it warms up. then starts the same hesitation and it is apparently going to do that until it has sat overnight. only runs good till it comes up to operating temp. There is a little temp sensor on the water pump, I am going to replace it 1st since its easy to get to. It might need a fuel filter as well its been about 60k since it was replaced. Injectors are for sure a concern though with the milage on this car. Thanks for the help.
12-22-2011 10:45 AM
31Vicky What about the fuel injectors?
12-22-2011 10:31 AM
7hr Reaperxx
1994 corvette hesitation

I have a hesitation and have had this problem several times with varying symptoms. this time I am kinda stumped. The car doesn't turn on its check engine light and runs like it has a bad tank of gas. Idles a lil rough but when you give it trottle it seems to be... a few cylinders short, runs ok at full throttle but pings. (and heads for ditch) lol Have recently changed the oxygen sensors as they were bad (checked with a scan tool). no codes no info from scan tool. what could cause this to happen and not throw a code. mass air is not new but has less than 50k in it same with water pump and optispark, there are no leaks I can see near the opti-spark so I think Its ok. The car itself has 187k on it ussually runs great no knocks and good compression on all cylinders.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.