Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> Dodge 1998 1500 Ram SS/T Transmission type?
User Name
Password
lost password?   |   register now

Thread: Dodge 1998 1500 Ram SS/T Transmission type? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-30-2011 07:15 PM
tnsmith10
Quote:
Originally Posted by SpiderMartin
I will let you know how it goes, I can not thank you enough for all you information and time,
no problem. i enjoy trying to help others. since this is the field im in, i do what i can.
12-30-2011 07:10 PM
SpiderMartin
Re : Ram 1500 SS/T transmission isssue.

I will let you know how it goes, I can not thank you enough for all you information and time,
12-30-2011 07:07 PM
tnsmith10
Quote:
Originally Posted by SpiderMartin
Yes, it has high mileage 170,****. The fluid is level and not burnt, no noises from the tranny. I thought I saw a cable for the throttle. Could it be a cable adjustment issue?
Yes, the RPMs have to rise before the truck will take off. This begain to happen and then the dash light came on and stayed on. Also on occasion the tranny slips in 4th gear, under a load.
My buddy that read the code re set the dash light and it came back on. I will have to check the harness that you mentioned, that is just fantastic info.
Thank you for more great information on this repair. I have a basic repair manual for basic referance.
with what you described and combined with the mileage of the truck, im afraid that doing a repair is going to be short lived if it works. im willing to bet that a pan drop will show that the trans has lived its life (and then some. lol)
more than likely, its time for a rebuild.
12-30-2011 05:32 PM
SpiderMartin
Re : Ram 1500 SS/T transmission isssue.

Yes, it has high mileage 170,****. The fluid is level and not burnt, no noises from the tranny. I thought I saw a cable for the throttle. Could it be a cable adjustment issue?
Yes, the RPMs have to rise before the truck will take off. This begain to happen and then the dash light came on and stayed on. Also on occasion the tranny slips in 4th gear, under a load.
My buddy that read the code re set the dash light and it came back on. I will have to check the harness that you mentioned, that is just fantastic info.
Thank you for more great information on this repair. I have a basic repair manual for basic referance.
12-30-2011 04:47 PM
tnsmith10
Quote:
Originally Posted by SpiderMartin
Thank you, that answered my question. I had the code read and that is what it told me it needed.
The issue is the dash light came on a while back and ever once in a great while, the tranny slipped into neutral. Back of the throttle for a second or two and all is well. (it has not happened in 5000 miles at least.) And when you give it gas it takes a second or two to take off, slow response?
I have had this issue with other vehicles and have changed external selinoids but not an internal. I spoke with a buddy that was familiar with mopar and he said he just replaced one in his brothers Ram 1500, same MO.
All fluids are level, I will change the filter and gasket, with the repair.
I am open to any suggestions and advice.
Thank you for the great info, and very quick response to my question.
so when you say that it is slow to respond to throttle, does the engine rpm come up before the vehicle moves? also, does the truck have a throttle cable to the throttle body or is it what they call a "fly by wire" setup?
i also didnt get the info from you on the mileage of the truck, or the level and condition of the fluid (remember, it needs to be checked running in neutral).
if its hi mileage, before you get too far, id drop the pan and inspect for debris, along with pulling off the harness connector to the trans and make sure that its not wet inside. its a 8 pin connector above the neutral switch.
if the pan has shiny material in it and the magnet is loaded with "fuzz", i wouldnt bother with the repair as most likely it will only get worse.
as far as the lockup solenoid/o.d. solenoids, even though they do fail, its not real common to see.
12-30-2011 01:46 PM
SpiderMartin
Re : Ram 1500 SS/T transmission isssue.

Thank you, that answered my question. I had the code read and that is what it told me it needed.
The issue is the dash light came on a while back and ever once in a great while, the tranny slipped into neutral. Back of the throttle for a second or two and all is well. (it has not happened in 5000 miles at least.) And when you give it gas it takes a second or two to take off, slow response?
I have had this issue with other vehicles and have changed external selinoids but not an internal. I spoke with a buddy that was familiar with mopar and he said he just replaced one in his brothers Ram 1500, same MO.
All fluids are level, I will change the filter and gasket, with the repair.
I am open to any suggestions and advice.
Thank you for the great info, and very quick response to my question.
12-30-2011 01:27 PM
tnsmith10
Quote:
Originally Posted by SpiderMartin
Hay, I have 1998 1500 SS/T 5.9 2WD , I need to replace the shift solenoid. I need to know if my transmission has a lock out convertor or not.
Thank you for any info
with this trans, its not as simple as replacing a shift solenoid as there is only one in the pan and thats for 4th gear.
a very common problem with these units is the governor pressure sensor and governor pressure transducer. if they fail, the trans will not shift. the key info here at this time is,
whats the sypmtoms, hows the condition and level of the fluid, and how many miles are on the trans, and lastly, have you had it scanned for codes?
also, for added info, all the "RE" units (95-up) all came with a lockup converter from the factory.
12-30-2011 10:13 AM
SpiderMartin
Dodge 1998 1500 Ram SS/T Transmission type?

Hay, I have 1998 1500 SS/T 5.9 2WD , I need to replace the shift solenoid. I need to know if my transmission has a lock out convertor or not.
Thank you for any info

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.