Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> chev power steering pump to a ford rack
User Name
Password
lost password?   |   register now

Thread: chev power steering pump to a ford rack Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-28-2013 07:37 AM
astroracer
Quote:
Originally Posted by Dave57210 View Post
My current set up is all Chevy, but I have driven one that had a Ford rack and a GM pump. There was NO road feel or feedback to the wheel at all! You could spin the wheel like a roulette wheel and the result was (in my view) extremely dangerous. There was no "self centering" of the wheel so it was way TOO easy to overcorrect at speed. I could see this as an accident looking for a place to happen.
I don't think you can blame that on the steering system. Most of your "self centering" should be handled by the caster side of the spindle alignment. If the suspension is not set-up correctly, or was built using mis-matched parts, this will cause most of the issues you were relating too.
Running a GM pump on a Ford rack will usually cause a "twitchy" feel. GM pumps run at around 1200 or 1300 PSI where as Fords MII racks require about half that pressure. Putting a reduction valve in the output side of the pump will help cure that.
Mark
10-27-2013 10:00 PM
Dave57210 My current set up is all Chevy, but I have driven one that had a Ford rack and a GM pump. There was NO road feel or feedback to the wheel at all! You could spin the wheel like a roulette wheel and the result was (in my view) extremely dangerous. There was no "self centering" of the wheel so it was way TOO easy to overcorrect at speed. I could see this as an accident looking for a place to happen.
10-26-2013 01:32 AM
jayd_2
Quote:
Originally Posted by burrpenick View Post
I have a Ford Ranger power rack but I prefer not to hook up the GM pumthat was included. Some say it w/b too hard to steer? Its light- somewhat narrow tires/weld wheels, no hood/fenders/bumper. If it is hard will the GM pump be too strong? Valves are expensive, whats the spring and/or other method you mentioned? Will any FORD manual rack fit the Ranger suspension? Not sure if the ranger rack was ever made manually (I have an EDGE with the TORSION BAR suspension, NOT COILS. thanks, George
There's an adjustable regulator available it bypasses flow from the high pressure side back to the reservoir via the return line, this allows you to fine tune the flow pressure.

I ended up fabricating adapters to mount a Mopar pump on a SBC, it's from the same model car that the rack came from problems solved.

I don't have any use for the regulator if you're interested.
10-25-2013 07:09 PM
burrpenick
help

I have a Ford Ranger power rack but I prefer not to hook up the GM pumthat was included. Some say it w/b too hard to steer? Its light- somewhat narrow tires/weld wheels, no hood/fenders/bumper. If it is hard will the GM pump be too strong? Valves are expensive, whats the spring and/or other method you mentioned? Will any FORD manual rack fit the Ranger suspension? Not sure if the ranger rack was ever made manually (I have an EDGE with the TORSION BAR suspension, NOT COILS. thanks, George
01-18-2012 10:54 AM
Centerline Welcome to the forum. I'm sorry you rolled your new rod... but your experience is a good example for anyone who purchases a car that has been built by someone else. Caveat Emptor..... may the buyer be where. Buyers need to completely familiarize themselves with all aspects and idiosyncrasies a car might have, and if something is wrong or not to their liking they need to fix or modify the car before just charging off to the local car show. I'm not by any means saying you did this... just that your experience is a good example to novices as to what can happen.

Yes, if there isn't some kind of pressure limiting modification done to a Chevy pump when hooked to a Ford rack, the steering will be a bit "twitchy" but this alone won't cause an accident. There are two or three different solutions to this problem and they all work well, although to different degrees. I always use the pressure spring to lower the pressure while others prefer a valve to do the job. Both work but which one you use is based on personal preference.

Again, sorry you had this problem and I hope you enjoy your ride.. once it gets back on the road.

Centerline

HotRodsAndHemis.com

"I don't know the key to success, but the key to failure is trying to please everybody." - Bill Cosby
01-18-2012 10:01 AM
jayd_2 I'm using a GM pump hooked up to a Chrysler rack & pinion, fortunately the truck was on jack stands for testing. I started the engine and everything seemed fine until I moved the wheel to the left a little it immediately shot to the right so fast it nearly broke my thumb. Two things were wrong, first the pump put out to much pressure and the rebuilt rack had been plumbed backwards making left right and right left.

The pressure issue was solved with an adjustable power steering valve. It works by sending excess pressure to the return line, this design does not depend on a spring to regulate pressure making it simple and safe, of course I also switched the lines on the rack. I'd read where GM used more pressure than Ford or Chrysler that's why I tested it on stands before driving it. Here's a link to the valve - http://www.speedwaymotors.com/Adjust...lve,14895.html

So far everything works great, I've done multiple quick left/right steering test at up to about 45 mph, I have a few more things to do before going any faster.

I had a bad experience with a chopped '30 Model A I built a few years ago, drove great at 40 mph but the first time I tried highway speeds all hell broke loose, I wanted to go left and the car wanted to go right. This was caused by suspension induced steering, it was solved with a Panard Bar, I've been driving it for over 5 years with no more steering problems.
01-18-2012 08:53 AM
454 Rattler Sure sorry to here about your rollover. Is the car totally gone ? I hope the insurance steps up and takes care of it.

Tell us about how the car acted going down the road. Some people around here say their car feels "twitchy" with the Ford/Chevy steering setup.

Any help would really help lots of people.

Welcome to HR.com.


454 RATTLER
01-18-2012 08:21 AM
S10xGN
Quote:
Originally Posted by potter7482
I had a roll over with my 34 ford because the guy that built the can didn't know to but a valve to control the pressure of the chev pump to the ford rack . This almost cost me my life. I am new to this site and love hot rods. This problem has cost me 75000 dollars .
Welcome aboard! Sorry to hear about your wreck, but I'm not understanding how the control valve would cause it. I'm sure the steering would "feel" different, but unless there was a mechanical failure how can you blame the valve?

Russ
01-18-2012 06:53 AM
potter7482
chev power steering pump to a ford rack

I had a roll over with my 34 ford because the guy that built the can didn't know to but a valve to control the pressure of the chev pump to the ford rack . This almost cost me my life. I am new to this site and love hot rods. This problem has cost me 75000 dollars .

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.