Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> The "What Did You Work On Today" thread
User Name
Password
lost password?   |   register now

Thread: The "What Did You Work On Today" thread Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Yesterday 09:39 PM
MARTINSR Ok, I found what I thought was the problem, I had installed the "clutch beam bracket" (bell crank thingie) wrong! It was too far up on the frame bracket allowing it to go forward too far. So I got that right and now it seems like the fork is screwed up, it moves around, I don't get this.

Brian
Yesterday 10:24 AM
MARTINSR
Quote:
Originally Posted by Too Many Projects View Post
You need to have a helper work the pedal slowly thru the full travel and watch the movement of all the pieces to see what it's all doing. Hopefully, you will see something that doesn't look right and find the issue.
Yeah, I did that but will again, thanks.

Brian
Yesterday 10:23 AM
MARTINSR
Quote:
Originally Posted by boothboy View Post
Here you go Brian. I hope these help make things a little clearer. Pretty goofy set up for sure!

BB
Thanks, I was actually sitting on my couch last night studying the manuals with this exact photos last night. I'll get back under there and take another look.

Brian
Yesterday 10:22 AM
MARTINSR
Quote:
Originally Posted by Too Many Projects View Post
Looking at this pic, I'm wondering if there was a pivot ball on the end of the clutch rod that fell off when the strap broke and is missing ?

No, thanks, but it's all there. But toss out anything that pops into your head, THAT is what will help me! Thanks!

Brian
Yesterday 09:17 AM
boothboy
Quote:
Originally Posted by Too Many Projects View Post
Looking at this pic, I'm wondering if there was a pivot ball on the end of the clutch rod that fell off when the strap broke and is missing ?

Here you go Brian. I hope these help make things a little clearer. Pretty goofy set up for sure!

BB
Yesterday 05:58 AM
Too Many Projects Got this new gauge panel for the '38 in the mail. Now I need to start a gofundme account to buy the gauges...



Yesterday 05:41 AM
Too Many Projects Looking at this pic, I'm wondering if there was a pivot ball on the end of the clutch rod that fell off when the strap broke and is missing ?

Yesterday 05:21 AM
Too Many Projects
Quote:
Originally Posted by MARTINSR View Post
I got Marge out of rehab! She promised she wouldn't relapse and I believed her. But on the first test drive, I am thinking she has already hit the hard stuff again. Things weren't right, the clutch pedal had an odd feeling.
Brian
Quote:
Originally Posted by Too Many Projects View Post
Does the inspection cover open up the entire bottom of the bellhousing ? If you can see in, look for a broken/bent tang or crack at the pivot ball socket on the fork. I assume there are no strange sounds such as a throwout bearing failing ? Is the pressure plate the old Borg and Beck style with just 3 fingers ? is one of those bent/broken ?
Quote:
Originally Posted by MARTINSR View Post
I got Marge up on the jack stands, pulled the covers off and played a bit with the linkage, thought I had it, but alas, nope. I can't understand this.
Brian
You need to have a helper work the pedal slowly thru the full travel and watch the movement of all the pieces to see what it's all doing. Hopefully, you will see something that doesn't look right and find the issue.
03-22-2017 11:36 PM
MARTINSR I got Marge up on the jack stands, pulled the covers off and played a bit with the linkage, thought I had it, but alas, nope. I can't understand this.

Brian
03-22-2017 09:18 PM
Too Many Projects
Quote:
Originally Posted by Rodnit View Post
Was thinking about you. Had the wife and daughter. Went to talk to our Financial Advisor at RBC. He moved from a different bank and we followed. Sounds like all his accounts followed. Got out about suppertime. We're about 3 hrs away.

May road trip back with the rod this summer. I'll give ya a heads up....
Sounds good. Any thoughts on doing BTTF this year ?
03-22-2017 07:38 PM
Rodnit
Quote:
Originally Posted by Too Many Projects View Post
Jeez, shoulda gave a shout beforehand. I'm 8 miles from downtown...
Was thinking about you. Had the wife and daughter. Went to talk to our Financial Advisor at RBC. He moved from a different bank and we followed. Sounds like all his accounts followed. Got out about suppertime. We're about 3 hrs away.

May road trip back with the rod this summer. I'll give ya a heads up....
03-22-2017 07:29 PM
Too Many Projects
Quote:
Originally Posted by Rodnit View Post

BTW, I was in your neck of the woods a week ago last Friday, 10th. Downtown Stillwater....
Jeez, shoulda gave a shout beforehand. I'm 8 miles from downtown...
03-22-2017 07:15 PM
Rodnit
Quote:
Originally Posted by Too Many Projects View Post


X2 and I think Troy meant "Hope nothing BUT the best for you"...
Thanks Mitch, that's what I meant say....

BTW, I was in your neck of the woods a week ago last Friday, 10th. Downtown Stillwater....
03-22-2017 06:33 PM
Too Many Projects Getting close to the last pieces of floor replacement on a '65 Impala.





Small patch on the toe board to fill in what the replacement pan doesn't cover.

03-22-2017 06:17 PM
Too Many Projects
Quote:
Originally Posted by idrivejunk View Post
Heres a "just rolled in today" for them who speak red Super Sport to look at. Gen VI, metric 454 with alum heads already. I don't know that I've seen one that still has the tabs on the gutter. Nice ride!
My Chevelle has all the tabs...

Quote:
Originally Posted by MARTINSR View Post
I got Marge out of rehab! She promised she wouldn't relapse and I believed her. But on the first test drive, I am thinking she has already hit the hard stuff again. Things weren't right, the clutch pedal had an odd feeling.


Brian
Does the inspection cover open up the entire bottom of the bellhousing ? If you can see in, look for a broken/bent tang or crack at the pivot ball socket on the fork. I assume there are no strange sounds such as a throwout bearing failing ? Is the pressure plate the old Borg and Beck style with just 3 fingers ? is one of those bent/broken ?

Quote:
Originally Posted by Rodnit View Post
Hope you're doing ok. You're the 2nd person in the last 2 weeks that had a mini stroke, if there is such a thing..... I guess there is..... Hope nothing for the best for you.......
X2 and I think Troy meant "Hope nothing BUT the best for you"...
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.