Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Engine Alive. But Idles to High
User Name
Password
lost password?   |   register now

Thread: Engine Alive. But Idles to High Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-09-2002 06:34 PM
78 monte My old Quadrajet had a problem w/ the secondaries sticking open.Check on the butterfly shaft for the secondarys on the passenger side theres a little lock there that allwas used to be a problem on mine.
Also when you put the carb on did you hold the butterflys open to make sure they cleared the intake.Some times they'll stick.
07-09-2002 05:35 PM
Dave E Shank Zeeman: I had this trouble twice. First time linkage was slightly bent and allowed secondaries to be cracked open at idel. Second time choke linkage was hung up on carb gasket that stuck out too much. Sometimes it is the little things Dave E Shank
07-09-2002 04:31 PM
Tom hey Zee is that carb new or is it an old one,and did you fix the lines? if you open the secondary air valve look down inside and see if the secondary throttle plates are open,if they are get them to close,check the primaries also. unscrew the throttle adjustment screw(located on the driverside of carb by throttle shaft),back off the fast idle screw(located on the pass side under the choke housing)if these things don't bring down the idle try moving the distributor counterclockwise slowly till engine slows down.if it still idles too hi there may be a problem with the well plugs leaking severely these are located under the carb and it will have to be pulled off the manifold to fix them ,let me know what happens
07-09-2002 04:00 PM
zeeman19
Engine Alive. But Idles to High

The engine finally runs. Its load as heck. But for some reason its idling way past 5000. Its a sb chevy 350 with a quadraject 4bbl carb. i tryed adjusting the carb but didnt help maybe I did it wrong. Please help me out. Thanks

Zee

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.