Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Modern Electronic Engines> 89 tbi 5.7 running poorly no power at low rpm or half throttle
User Name
Password
lost password?   |   register now

Thread: 89 tbi 5.7 running poorly no power at low rpm or half throttle Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-10-2012 07:25 PM
monsterchevy355 I figered it out. damn tps had short. put another used one on n goin strong again
03-10-2012 02:20 PM
monsterchevy355 I just checked fuel pressure an hour or so ago and it reads bout 12 or 13lbs. I got to messin with the temp sensor plug and i think thats been my problem all along. I unplug it and it runs like a dream. gobs of power, good throttle response and no hessitation. also unhooked batt and cleared computer now its throwing code 22. As of right now iv got an old temp sensor pluging the hole and have the one i pulled out laying on intake with it pluged in and the truck runs perfect. I unplug it it still runs fine. Plug it in to the other one plugging the hole it idles way down, becomes doggy and hessitant and no power. Same way if i swap sensors and plug it in it runs like **** but if i unhook it its night and day difference.
03-10-2012 02:09 PM
LATECH The tach and fuel gauge sound like a ground wire problem.
The running problem sounds like a fuel pump. It too could be a ground problem. Need to check over your grounds, there should be at least 4.
One from battery to engine, will be large batt cable. One from negative post to rad support. One from engine to firewall.Also it should have one from engine or body to the frame, prefferably from the engine to frame, as the fuel pump grounds through the frame.
If all checks out, perform a fuel pump pressure test.
It probably wont have a test port for PSI test, so you will need to rig something up. You also will need a good gauge that reads small pressure, like 20 pounds on at least a 180 degree sweep.The TBI runs about 13 pounds. Using a gauge that reads say 60 pounds wont give an accurate assesment as the scale is too big.Hence the 20 psi range. If the pressure drops to 7 or8 ponds, it wont be easy to tell if the gauge reads a scale that is too large.
03-10-2012 11:29 AM
monsterchevy355
89 tbi 5.7 running poorly no power at low rpm or half throttle

iv got an 89 fullsize chevy with a 5.7 tbi and 5speed with ceramic clutch. Its been runnin like complete **** latley and im stumped of figuring it out. Started pullin my hair out yesterday after if left me walking twice in 1 hr and seriously thinkin bout throwin the tbi and intake away for a carb. its thowing several codes a 12 15 33 34 32 The motor is a reman replacement and idk how to find out if its still under warrenty. It is real doggy around 1 to 2.5 grand and seems like its got a dead spot in throttle. runnin down highway it will stall out and stay stalled untill i take my foot off gas then its fine untill i push petal halfway it will stall again like i shut the key off. Also at the same time it stalls my tach will stick and my temp guage goes crazy. I apriciate any help anyone can give me. If there is anything else you need to know ill glady post

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.