Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> 67 Camaro pwr steering pump
User Name
Password
lost password?   |   register now

Thread: 67 Camaro pwr steering pump Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-04-2012 04:01 AM
EOD Guy Thanks for the replys, the issue isn't the foam or bleeding the air out, it's the amount of pressure it's producing..... ie..... shooting a 3 foot stream out the vent hole on the new remote tank. I'm looking for a new stock gm flow control valve, but not having much luck locating one. Not intrested in the adjustable type, just the plain old stock one.
04-03-2012 10:41 PM
enjenjo You may have a defecive accumulator on the hydroboost, but it does take a while to bleed all the air out. It does foam more if you are using ATF and not regular power steering fluid.
04-03-2012 08:29 PM
ogre i have a hydroboost under the floor on my 58 truk.
it foamed for a bit but once the air was out it was good.
my truck has a mustII rack, i ran it full left, full right and left again
pressed the pedal to the max a couple of times
let it sit, filled it up and all was fine
new rack, used hydro off an 03 cobra

got to remember that the accumulator is similar to a bladder tank
full of air until it gets bled out
if it's pointed up hill at all it may take a bit to get the air out
04-03-2012 07:09 PM
EOD Guy
67 Camaro pwr steering pump

I have a SBC in a 67 Camaro, it has a stock pwr steering pump, the old banjo style. I have a big cam so I swapped the vacumn booster out with a hydro boost unit. It works well except the fluid started to foam and then the system didn't work so well, let it sit and all is well for awhile....... so I got a remote resivoir and mounted it on the firewall etc..... the issue is the fluid shoots out the vent hole in the cap.

All the lines are stainless with AN6 fittings, two return lines from the hydroboost and the steering box into the resivoir and one to the suction side of the pump, one from the pressure side of the pump into the pressure inlet hydoboost, one from the pressure out on the hydroboost to the pressure side of the steering box

Any suggestions on how to remdy this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.