Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior> 73 buick
User Name
Password
lost password?   |   register now

Thread: 73 buick Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-01-2012 11:02 AM
swvalcon Just used the production to cut costs a little because I'am way over the bid on this car.
06-01-2012 10:46 AM
67Elcamino
Quote:
Originally Posted by 67Elcamino
What was the purpose of finishing off with production clear instead of Universal on all coats?
Sorry I just read your previous reply and answered my question
06-01-2012 10:44 AM
67Elcamino What was the purpose of finishing off with production clear instead of Universal on all coats?
04-30-2012 05:23 PM
swvalcon Not sure what you mean by layer them. I shot two coats of spi production mixed 4-1-1 with a mid temp reducer about a half hr between coats. Then shot my last coat or third coat with production mixed at 4-1-1 and about a half qt of spi universal mixed at 1-1-25% mid temp. I talked to Berry one day when I was in the middle of a job and was low on production but had some universal. I asked him if I could mix the two and he said yes as long as both were pre mixed in the right amounts before I poured them together. I liked the end results and had mentioned to him that I liked the production clear but didn't care for the way it buffed. He said the adding the universal should help that. I've started to buff this thing and cut it with 600-1000-1500 on the da. Then 2000 wet and it buffs just like buffing out universal and looks like glass.
04-30-2012 04:21 AM
deadbodyman Why did you layer them and why mix them together ???
04-28-2012 04:22 PM
swvalcon Got the thing painted and cut and buffed a little of it. Should be done with it this next week. Picture of drivers fender buffed. three coats of spi clear, 2 of production clear and the third a 50-50 mix of production and universal.
04-26-2012 08:46 AM
swvalcon Put down 3 coats of omni. base yesterday let it dry overnight. Wet sanded out any dust specks and dry spots that I didn't like. Sweept out the booth, wet the floor and tacked off whole car including masking paper with old tack rag. I save old still usable tack rags specially for this. Now I will give it a double wet coat of base with 25% hardener in it wait about 4 hrs and start to clear
04-25-2012 01:04 PM
swvalcon In sealer ready for paint.
04-24-2012 05:24 PM
swvalcon A dark green Pearl from a 2010 jag. Almost looks black with no sun light. I told the guy this wasn't to be a show car so if there's a wave or two he'll have to live with it if he want that dark of a color. It is a Sharp color though.
04-24-2012 05:02 PM
deadbodyman I'll bet your glad this one's done...What color you going with??
04-24-2012 04:18 PM
swvalcon Got her ready to paint and in the booth.
04-11-2012 06:59 PM
swvalcon For some reson it didn't load the picture so will try again.
04-11-2012 06:55 PM
swvalcon Got it almost ready for paint let it dry in the sun good today and hope to wet sand and mask for paint tomorrow. Should be in paint this weekend.
04-01-2012 07:09 AM
swvalcon Got the rt 1/4 panel done and in epoxy so now it's just let everything dry good and wet sand for paint. Should have the jambs done this week and maybe start to paint. The owner was over and looked at it yesterday and he's happy with the way it looks.I'll post some pictures when it's done.
03-30-2012 09:59 AM
swvalcon Got the header wet sanded with 400 ready to paint and finished the rt 1/4 panel bodywork. See if I can get lucky twice in a row and have this one as straight as the other side. If I do I'am feeling real good about my mega millions numbers for tonight.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.