Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> 70 roadrunner electrical headache
User Name
Password
lost password?   |   register now

Thread: 70 roadrunner electrical headache Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-22-2003 09:00 PM
Pony Bought a 1070 Dodge 440R/T a few years back, and car would go dead and owner said "just beat the dash a few times and it'll start right back up!!) As I wasn't too happy with that arrangement, I went hunting and it was the Amp gage. Had white powdery corrosion inside/outside, Replaced it with a under the dash oil/amp gage set-up and life was fine. Good luck.
09-22-2003 01:00 PM
Drew Francis Hey magnus thanx for response will try new amp meter and see if that does the trick, thanx for your help! drew
09-21-2003 09:33 PM
Magnus_Jager Well from my experience with 70's dusters the amp meter is always live and if it goes to bad the whole electrical system can fail.

So have you checked / replaced the amp meter? Possibly explain no power unless running.

Mine was literaly cooked, burnt around the post, and it would fade in and out. I would lose all electric, motor would even die. I had to go outside the car and do the old starter relay bridge to kick the starter.

Also when you replaced the alternator did you make sure your fied wires where on the right pins. If they are wrong the alternator will over charge.

Thats just a couple things to check out.

Jim
09-21-2003 09:15 PM
Drew Francis
70 roadrunner electrical headache

Any help would surely be welcomed. 70 roadrunner sitting in body shop for 9plus months. Turn key, car engine starts but when let go of key won't keep running, so body shop guy hot wires coil to battery, car starts and runs, diconnect hot wires and car turns off. This is my first problem.Next, while i was attempting to replace light bulbs in dash,stupid me forgot to disconnect battery and bumped amp meter against metal dash board,than see small puff of smoke come from voltage regulator. I replaced voltage regulator, alternator, starter relay, and battery, all were old. Now I start car up and everything gets very bright, blows a few bulbs and i turn car off. After this i now have no power to my dash, when i open door, i have no dome light, parking lights ect. Only when i start car I have dome light, headlights,ect. Could i have blown out switches in my dash? What else could i have hurt by bumping amp meter on metal? Thanks for help, sorry this is such a long message.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.