Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> Front shocks 51 Styleline
User Name
Password
lost password?   |   register now

Thread: Front shocks 51 Styleline Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-01-2012 02:57 PM
Supercharged03 The reinforcement you have looks like what I recall from mine. Your solution should work fine.
06-29-2012 02:13 PM
brian720
Lower shock mounts

These apparently fail frequently as per 2 parts houses. One supplier told me most buyers get 3-4 at a time. The obvious solution to me was to build a better mouse trap. I'm sure I am not the first person to figure this out. I had the broken tab tack welded in place and then had them add a reinforcing piece of steel in the bottom side of the mounting bracket. That necessitated driving the small mounting stud out of the lower suspension arm. I replaced that with a 1" x 3/8" bolt and used a compression nut. The fit was perfect, and there is plenty of room to use a wrench on the bolt head. I don't think these mounts will fail. The car rides fine and the shocks mount just as before. Spraying some PB Blaster on the studs and letting it sit over night made them very easy to tap out. Put a nut flush to the edge of the stud if you don't want to ruin it in the removal process. A few light taps with a heavy ball pean hammer took them both out.
06-28-2012 07:58 PM
Supercharged03 One of mine was broken and re-welded by a previous owner with reinforcement on the nut side so the mounting stud did not have to be replaced. Can you post a photo?
06-26-2012 09:03 AM
brian720
Chevy shocks

Yes thanks,
I'm aware of how the lip fits. Seems as though the person who put the shocks on wasn't. I got my car about 80% done and the rest for me to piece back together. They put the mount on just with the small stud holding it all. It lasted about 150 miles and both have broken off. The design itself looks weak, and the parts houses say they sell these 3-4 at a time to car owners. I am thinking of welding the tip back with some re-enforcement on the arm end. That means I have to remove the stud and through bolt them in place. I am just shopping for ideas and experience from other builders like yourself. Thanks.
06-25-2012 08:31 PM
Supercharged03 These shock mounts have a lip that goes into the hole in the lower control arm. The lip is opposite of the hole for the stud. Test fit the mount without the shock attached. It'll be very apparent when it's going in correctly.
06-25-2012 01:42 PM
brian720
Front shocks 51 Styleline

Anyone familiar with the proper installation of front shock lower mounts on 49-54 Chevy? Also, has anyone successfully modified the mount as they are really thin around the locking bolt and snap off pretty easily? I am thinking of driving out the locking stud to replace with a bolt, and the reinforce the flimsy edge of the shock retainer. Do these retainers bottom out under the a-arm, or slip over it to have resistance against downward pressure on the front of the car?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.