Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> TCI 700R4 Trans pressure bouncing around?
User Name
Password
lost password?   |   register now

Thread: TCI 700R4 Trans pressure bouncing around? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-18-2012 07:09 PM
Hawkfan
Thanks Rick

Thanks for the input Rick. I had various conversations with TCI yesterday and they too pointed to the sticking valve. I followed their reccomendations, made some adjustments on the TV cable, took the car for a ride and it appears that everything has come together.
Again, Thanks Rick.
07-17-2012 09:24 PM
rick 427 That pressure should... A] stay about the same going from park to drive B] not be that high at MIN T.V.pressure[idle] C] not bounce around;all assuming the motor is at a decent idle rpm.......so try this first...see if the pressure goes even higher as you increase the engine rpm's,for reference purposes,and they SHOULD NOT,as those #'s are MAX t.v #"s [w.o.t.],not min t.v.#'s that you are reading now ......then try backing off the T.V. cable adjustment, and see if the pressures settle down. It should be in the 75-90 psi range at min T.V.[idle] in P and OD / 3......rev. will be a bit higher, manual 2 and 1 higher yet,about 150 psi. And as the rpm's increase,the psi #'s will go up in P-R-OD and 3......see what happens at that point.......if the pressure doesn't settle down into those #'s, it's possible that the pressure reg. valve in the pump is hanging open.
07-16-2012 06:03 PM
Hawkfan
TCI 700R4 Trans pressure bouncing around?

I have a TCI 700R4 trans hooked up to a 454 with a mildly modified cam. When I try to do a trans pressure check, the pressures jump around from approximately 140 to 160 psi while in park. When I put it in gear, it will drop to about 120, hold steady for a moment then start bouncing around again.
Would this be normal due to the modified cam? Im trying to adjust the TV cable and the directions say to move the slider until the pressure changes by 2 to 4 psi and thats hard to do when the pressure is bouncing around.
Any input would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.