Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> S10 355 brakes don't work very well
User Name
Password
lost password?   |   register now

Thread: S10 355 brakes don't work very well Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-22-2012 10:28 AM
ttjsk812@aim.com Okay! do you know anything about wiring one up deuce?? And running a relay or fuse for it?
07-22-2012 08:27 AM
Deuce
Quote:
Originally Posted by ttjsk812@aim.com View Post
So you dont have to get the vacuum out of the engine? Just plug it off orr what?
NO ...

The electric vacuum pump is the ONLY supply of vacuum that the booster needs to function correctly. Plug the line from the carb to the booster. Keep the line from the carb to the vacuum advance on the distributor if yours has one.

07-22-2012 12:01 AM
ttjsk812@aim.com So you dont have to get the vacuum out of the engine? Just plug it off orr what?
07-21-2012 10:22 PM
Deuce You hook it to the brake booster ... not the carb.
07-21-2012 07:02 PM
s10quint Not sure. That's why you need the wiring diagrams. It'll take the guess work out of it.
07-21-2012 06:35 PM
ttjsk812@aim.com Alrite how do you run a relay or fuse off it and do you have to have a switch so it shuts off once it reaches a certain bacuum
07-21-2012 06:30 PM
s10quint Get yourself copies of the wiring diagrams for your truck & the donor vehicle. If you wire it inline with the ignition coil or another wire that only gets power when the switch is turned on, you should be fine. Should work on any type of vehicle. Foreign or domestic. Good luck!!!
07-21-2012 09:03 AM
ttjsk812@aim.com Would one work from a Volkswagon or a saab or audii? also How do you wire these up and is there a switch you have to use so that it knows when to shut off?
07-21-2012 06:16 AM
ttjsk812@aim.com Yeahh I was looking at some on the ebay wondering if any woyld work rather than paying a lot for one through summit. Nowis tgere normally two fittings on those. Where do you hook in from the the vacuum line on carb to that pump?
07-21-2012 06:08 AM
Deuce It is COMMON for vehicles such as yours with a big camshaft to have issues with not enough vacuum for the brake booster. You need a separate electric vacuum pump.



Summit Racing has them.

Hella 009428087 - Hella Street Vacuum Pumps - Overview - SummitRacing.com

Or ... if you are salvage yard prone ( who is not ?? )
Find a diesel powered GM vehicle with the small 12V electric vacuum pump.

Buick
82 Skyhawk-J
82- 85 Skylark-X


Cadillac
82 Cimmaron
Chevrolet
84-86 Celebrity-A
82 Caprice-B
82 Cavalier-J
82-85 Citation-X
Oldsmobile
86 Cierra-A
82 Firenza-J
82-84 Omega-X
Pontiac
85-86 6000
82 J2000
82-84 Phoenix-X

I get them for less than 25 dollars used ... and they work perfect for a over cammed SBC.

I got this photo off the internet



DEUCE .. Moderator
07-21-2012 05:39 AM
ttjsk812@aim.com That is probably what i'll do thanks
07-20-2012 08:11 PM
s10quint I'd run the vacuum line from the intake manifold. You'd probably get a stronger vacuum, hence better brakes. I've owned vehicles without a brake booster & it's no fun. If the line from the intake doesn't work, put a vacuum canister in the truck. You can get them from Jegs, Summit, etc. for about $35-50. It just plumbs in & maintains a little pressure so it don't need a whole lot of vacuum from the engine when applying the brakes. A lot of old school racers use them. Especially on HOT street engines so they can keep the power brakes. Simple fix to old problem.
07-20-2012 02:43 PM
ttjsk812@aim.com
S10 355 brakes don't work very well

I have an 85 s10 with a 355 and a 536 lift cam. It is almost like I dont get enpugh vacuum for my brakes to work good. Is there any way I could get more vacuum to my brakes. What if I got rid of brake booster? replaced vacuum line from valve cover to booster because it was sucking shut. Brakes work a little better but not greatt. Any ideas??

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.