Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 4t60e transmission
User Name
Password
lost password?   |   register now

Thread: 4t60e transmission Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-22-2012 09:11 AM
thump1st Did that. Even drained the pan & put new fluid in it. Although for the last 3 days it hasnt been shifting correctly, it still has that whine sound to it.
Anyone else have any suggestions? And thanx to dgcantrellsr, for ur response
07-21-2012 10:36 AM
dgcantrellsr check the fluid level
07-20-2012 01:27 AM
thump1st
4t60e transmission

MY 1995 Chevy Beretta, has a 4T60E transmission. The Trans wont shift into overdrive. Shifts flawlessly all the way up to 3rd, but just wont get into 4th.What could this problem be? Also, b4 this happened it started making a whine sound. Thought it was the power steering but then this, no shift into overdrive happened.
Anyone with ideas? Truly appreciate it

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.