Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> new build feels under powered
User Name
Password
lost password?   |   register now

Thread: new build feels under powered Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-12-2012 04:54 PM
Project89
Quote:
Originally Posted by Pupsvette76 View Post
I'm not able to upload my file it will not allow me
upload it to mediafire.com its free and it will give u a link u can post here so i can download it
10-12-2012 12:30 PM
Pupsvette76 I'm not able to upload my file it will not allow me
10-11-2012 05:51 PM
Project89
Quote:
Originally Posted by Pupsvette76 View Post
Anything in particular. So I have an idea what I'm looking for
post ur tune ur running up on here and ill take a look at it and see if anything obvious sticks out at me as being wrong

if u cant post the tune file son here ( dont know if the board will allow u to attacjh it ) post it on mediafire and post the download link
10-11-2012 12:05 PM
Pupsvette76 Anything in particular. So I have an idea what I'm looking for
10-11-2012 11:39 AM
lmsport After spending some hours with a PowerjectionIII the last few days, I would suggest you spend some tuning it as it is not nearly as self-tuning as they claim. Also, you have to go their website and read through the forum cause there is some stuff posted there that is absolutely necessary to know that is not in the instructions.
10-11-2012 10:18 AM
Pupsvette76 I've been rseaserchng the afr 1050 Heads the have the big chamber I need large intake runner the are CBC ported and my friend at my speed shop can make me a good deal on them
10-11-2012 07:49 AM
hpete I think you need a cam with zero or negative overlap. As rpm builds the pressure in your exhaust increases to the point that it's higher than the intake boost. When the intake opens during overlap it's reversing flow because of the high pressure inside the cylinder. Another thing to think about is increasing the strength of your valvesprings because of the greatly increased pressures that their dealing with. The World Products heads that you mentioned would be a good choice, the 74cc heads that Engine Quest makes for IMCA racers would work well too.
10-10-2012 06:25 PM
Project89
Quote:
Originally Posted by Pupsvette76 View Post
Ok just an update I messed around with the fi today and got it pretty dialed in didn't do much tuning just kinda changing some preset settings and it will now hot like 5300 still low since the rev limiter is at 7k... But anyway I went into my log files and my afr at WOT will hit 9 for like a millisecond and then rebound and search for the target afr which is about 12 at WOT fuel pressure never drops off lowest number I saw was like 42 and I have it set to 45 boost refernced
theres ur problem now with a wideband u have to be carefull if the motor is going way lean it can give a false rich reading on the wideband.

same goes for the other way around.

so go into ur ve map and take away a lil fuel in the area were its going into 9afrs and see if it helps , if u take away some fuel and it gets worse then u know its a false rich reading and u have to add fuel instead

what fuel injection system did u say u were using, if u need it i canprolly lend u a hand getting the thing tuned and looking at the datalogs
10-10-2012 05:51 PM
Pupsvette76 Ok just an update I messed around with the fi today and got it pretty dialed in didn't do much tuning just kinda changing some preset settings and it will now hot like 5300 still low since the rev limiter is at 7k... But anyway I went into my log files and my afr at WOT will hit 9 for like a millisecond and then rebound and search for the target afr which is about 12 at WOT fuel pressure never drops off lowest number I saw was like 42 and I have it set to 45 boost refernced
10-10-2012 04:44 PM
Project89 what is ur afr when it does this, right off the bat u can eliminate the turbo and plug gap, since it does it in nuetral as well as gear, the turbo wont build boost during free rev.

still go ahead and tighten the plug gap anyways though

i would look into fuel system issues, for sure, get a fuel presure gauge and rev the motor up and see if fuel presure is droping


even with crappy heads he thing should deff rev up over 4800, hell even the cfi camaro motors will rev up higher then that and they have very very tiny ports
10-10-2012 09:54 AM
Pupsvette76 I have checked for wiped lobes and the cam is fine and all rockers were tight so that indicates no loose studs and I didn't notice and bent pushrods it does the same thing in neutral it will rev to 4800-5 and then stop no banging no rev limit sound just stop and then if I hold it then it will actually go back down the fuel system is a 255gph pump I bought the better pump with the kit 62lbs injectors with -8 feed line -6 return
10-09-2012 10:28 PM
Project89
Quote:
Originally Posted by Pupsvette76 View Post
Its a 70 nova with a turboed sbc 355 and a turbo 350 trans and 4.88 gears on a spool It doesn't pop or bang at all it just ceases to keep climbing in rpm and in fact if I hold the pedal Down even when it doesn't climb it will actually start to drop In rpm plug gap is .030 it's a new intercooler not sure exactly what core size I believe it's 27in long and 3in deep
ok let me post some videos for u in a lil bit, keep in mind the downpipe is only about 2.5 ft long so the noise u do hear would be very hard to hear if it had a full ex.

see if it kinda acts like what ur engine is doing.


have u checked the same for wiped lobes, possible rocker stud pulling out.bent push rod etc

will it rev in nutral or park?

whats the fuel system have for line size /pump what size injector
10-09-2012 09:46 PM
Pupsvette76 Its a 70 nova with a turboed sbc 355 and a turbo 350 trans and 4.88 gears on a spool It doesn't pop or bang at all it just ceases to keep climbing in rpm and in fact if I hold the pedal Down even when it doesn't climb it will actually start to drop In rpm plug gap is .030 it's a new intercooler not sure exactly what core size I believe it's 27in long and 3in deep
10-09-2012 08:29 PM
Project89
Quote:
Originally Posted by Pupsvette76 View Post
Not sure what gear would fit best I was thinking along the lines of. 3.55
are u still having trouble reving over 4k? if so what does it do , does the motor just fall on its face, or is it starting to miss and pop and bang?

if needed i can post a video of what it sounds like if the plug gap is to big and the ignition system isnt upto the task.my friends car i tuned would have the same symptoms at around 4,500 it wouldnt rev past there at all and would bang and pop.

went from .032 plug gap to .022 and its been flawless ever since.

what intercooler are u using is it something out of a junkyard car?if not whats the core size ?

genrally ur going to want something in the 32x12x4 range though a 32x12x3 will work for moderate hp levels

remind me again what car this is in and what trans ? 3:55 or one step down would prolly be a really good match . i do recall u saying no more then 5 psi in first gear. once u do a gear swap u will get alot more boost in first
10-09-2012 08:19 PM
Pupsvette76 Not sure what gear would fit best I was thinking along the lines of. 3.55
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.