Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> 1993 Chev 1500 4.3Z
User Name
Password
lost password?   |   register now

Thread: 1993 Chev 1500 4.3Z Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-31-2012 05:40 PM
rhossack
Quote:
Originally Posted by cobalt327 View Post
the holy grail of 4.3 info!! - S-10 Forum is some decent 4.3L info.

I don't recall what year the 4.3L V6 got a balance shaft. But basically you want to replace like w/like as closely as needed. By that I mean don't go '96-up, else the intake surely will not fit and there's no way to make it fit.
My local wrecking yard has a few reasonably low mileage engines (93-95) so I was going to get the complete engine so it comes with intake on it and I hope this isn't an issue then.

Thanks for the replies.
07-30-2012 08:42 AM
cobalt327
Quote:
Originally Posted by rhossack View Post
thanks for that info. Does it have to be a "Z" engine or will the "W" work with the computer?
the holy grail of 4.3 info!! - S-10 Forum is some decent 4.3L info.

I don't recall what year the 4.3L V6 got a balance shaft. But basically you want to replace like w/like as closely as needed. By that I mean don't go '96-up, else the intake surely will not fit and there's no way to make it fit.

And if you go back to '85, the engine had a 2-piece rear main seal and in '85-'86 the cam was a flat tappet. But '87 through '94 engines should work even though the cam specs weren't identical; the amount of vacuum they made was sufficient for the stock ECM to handle. Edelbrock sells a TBI performance intake for those years, p/n 3713.

Good luck.
07-29-2012 07:42 PM
va4cqd some W engines use a balance shaft so the Z intake may not fit
07-29-2012 07:40 PM
rhossack
Quote:
Originally Posted by va4cqd View Post
87 to 95 should bolt right in and work correctly with the TBI. you can probably find one from an S10 or astro van easier then one from a fullsize
thanks for that info. Does it have to be a "Z" engine or will the "W" work with the computer?
07-19-2012 12:58 PM
va4cqd 87 to 95 should bolt right in and work correctly with the TBI. you can probably find one from an S10 or astro van easier then one from a fullsize
07-18-2012 02:40 PM
rhossack
1993 Chev 1500 4.3Z

I bought this truck new and it now has 266+K on it and the engine is running very rough when it runs at all. I know cylinder 2 has 60 lbs and the rest are at 120-125.

I would like to swap out the engine for another 4.3 from another year if that is possible. What are my options?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.