Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Qjet stumble 360 Amc
User Name
Password
lost password?   |   register now

Thread: Qjet stumble 360 Amc Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-28-2012 02:36 PM
RWENUTS Getting stumped!!
Blow some carb cleaner thru the air bleeds that are located between the choke housing and the secondary air valve. In photo 2 in the link you see them 4 tubes that are attached to the top plate. Best to remove the top plate to check they're clear. I found one once that was pinched off.
You could try blowing thru them without lifting the lid.
Diagnostic Dilemmas: Servicing Quadrajet Carburetors: Underhood Service
08-28-2012 01:53 PM
UngerMarkus From the point where the spring doesn't close the air valve anymore I loaded the spring with one full turn.
08-28-2012 01:38 PM
UngerMarkus Thanks for your replies, guys!

I did what you suggested me and checked the PP with a screwdriver. It works nicely.
Unfortunately I forgot to write down the casting number. But it is a Jet performance light truck stage1 carb.

The APT was screwed out 4 turns. I tried everything from completely seated to 5 turns out in 1/4 turn increment. But it didn't make much difference. I also advanced the ignition a bit.

In D it drives badly. When I locked it in first gear it accelerates good as long as you open the throttle progressively.
When I floor it, it stutters badly and does not pick up speed. When you let off the gas a bit, it accelerates again.
08-28-2012 09:19 AM
RWENUTS How many turns on the screw are you at on the secondary air valve. Measured from zero adjustment. I tap on the air valve and when it won't try to close I call that zero.
08-28-2012 08:36 AM
raguza123 Ok you do know the secondaries still open, even when you tape the air valve off?
08-28-2012 08:32 AM
UngerMarkus I put duct tape over the air valves and the hanger to prevent them from opening.

I did what you said and checked the PP with a screwdriver. It seems to work smoothely.

As for the casting number, Im gonna check that and let you know. As far as I know its a brand new Jet Carb set up for Smallblock Truck engines.
08-28-2012 07:58 AM
raguza123 Also you could be too rich on the primary side for jetting. as it was suggested check the APT.
Check your pump stroke it may need to be larger stroke or decreased.
Check your choke if so equiped, it may not be opening up fully.
Your Power Piston may need a weaker or stronger spring.
A vacuum leak could be at the Throttle shafts.
Which Carb do you have, a number of the unit
08-28-2012 07:58 AM
RWENUTS Apt set too lean could cause a stumble or bog. Weaker power spring could cause that stuttering thing too.
Reach in the air vent in the top centre of the carb with a small screwdriver and see if you can push the primary metering rods down while the motor is shut off. They should move down easily and spring back up. I've had them hangup on the gasket before.
How did you disable the secondaries?
What's the elevation where you live?
Apt could be set too lean!
08-28-2012 06:41 AM
UngerMarkus In case the APT is not adjusted right could it cause problems like that?
08-28-2012 06:39 AM
UngerMarkus Hi guys. Today I disabled the secondaries. The engine has the same problems. As soon as you open the throttle more than half way it stutters, regardless of the speed. In neutral it revs up nicely.

So I assume the problem is on the primary side.

Any suggestions? I'm running out of ideas...
08-25-2012 04:53 PM
raguza123 It's worth a try, that will tell you if it's the primaries or secondaries that's causing the stumbling. One thing what will keep the throttle plates closed, they will still open?
08-25-2012 03:35 PM
UngerMarkus Hi guys! It's a mallory hei distributor. I tried both, ported vacuum and manifold vacuum. Manifold works best, but it didn't cure the problem. The secondary spring tension was the first thing I thought about too. I tried everything from very loose to very hard. The stuttering seemed to be a little less intense with the hardest spring tension.

The theory with the secondary wells not drilled seems more and more plausible.

What do you think about this test?:

In case there is something wrong with the secondaries, I could keep them from operating using some duct tape and tape them shut. Now the qjet should work like a 2bbl carb. If the stuttering at wot is gone, its obvious there is a fuel delivery problem that causes the engine to run lean.
08-25-2012 07:11 AM
raguza123 It sounds like your air valve is opening too soon, is your air valve opening too soon? if it opens too soon you'll get a rush of air and fuel and a bog.
Do you have a manual on tuning a Qjet, I have a factory manual I could send, I do believe your Qjet is out of adjustment? or maybe I'm wrong
08-24-2012 07:57 PM
RWENUTS Vacuum to distributor hooked to ported or manifold vacuum?
What distributor?
08-24-2012 06:56 PM
UngerMarkus Thanks, that's a great suggestion! I'm gonna check that ASAP.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.