Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> sbc pinging
User Name
Password
lost password?   |   register now

Thread: sbc pinging Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-10-2012 04:57 PM
sbnova Thank you will grt the figures.
09-10-2012 10:52 AM
cobalt327
Quote:
Originally Posted by sbnova View Post
HI my sbc 350/400 hp has a pinging problem. I currently have a mallory unilite distributor with vacum advance. I tried setting my total timing at 33,34,35 degrees and it did not help. I went back to base timing of 6,8, and 10 degrees and no change. The fuel has been changed to fresh 93 octane tried octane boost no good, I am thinking distributor I am currently trying the vacum advance adjustment by turning the allan key in the vacum advance canister counter clockwise to reduce the advance curve so far ng. does anyone have any suggestions? can the distributor be defective? should I try another maybe msd or pertronix? thanks for any help..
There were three different timing tab/damper TDC line combinations used on the Gen 1 SBC (not counting the plastic timing cover engines like the L31 Vortec, etc.). Mixing/matching the tabs and dampers can cause a false reading when you go to time it. More on the differences HERE.

Some info on setting up a timing curve is HERE.

Other possible causes for preignition is a hot spot in one or more cylinders. This can be a sharp edge left over from having the heads decked, or a bit of casting flash.

Be sure the spark plug heat range is not too hot. Obviously, vacuum leaks can dilute and lean the air/fuel mixture and that can add to being detonation prone. So be sure there are no leaks. You can remove all the hoses except for the vacuum advance and plug the ports to eliminate vacuum leaks coming from the vacuum accessories. Be sure there are no leaking intake or carb gaskets and that the PCV system is working as it should.

Check the color of the spark plugs to be sure the air/fuel ratio is not overly lean. Be sure the float level is right, fuel pressure adaquate (about 5 psi) and the filters are flowing properly (if in doubt, replace).

Another area to look at is the dynamic compression ratio (DCR). If the cam is very mild and the static compression ratio (SCR) is too high, the DCR will also be too high for pump gas in some cases.

THIS is one of the CR calculators that are online. Plug your numbers in and see what you get.

To see what the dynamic compression ratio is you need to know the rod length (stock is 5.7") and the intake closing point of the camshaft. This lets you estimate whether a combination of parts will be able to use pump gas w/o detonation, for example.

A couple calculators for dynamic compression ratio:
Dynamic CR

Another dynamic compression ratio calculator

Here is a short page on the compatibility of different cam durations to the compression ratio.

One last thing- do yourself a favor and read up on "quench". It's an important part of the engine build and can make the difference in having an octane hungry pinging engine or a smooth running engine w/o detonation.

Good luck.
09-10-2012 06:54 AM
sbnova Thanks but I am totally frustrated. Just unloaded , will try one at a time...
09-09-2012 06:22 PM
bigblockragtop Ok Most would recommend one change at a time. Good luck!
09-09-2012 06:21 PM
sbnova I was told so by mallory counterclockwise lessens the advance. I am still adjusting 1/4 turn at a time to see if it lessens. I am also going to re jet my holley up 3 size jets as the plugs are reading too lean which can also contribute to the pinging.
09-08-2012 09:45 PM
bigblockragtop Take it around the block w/o vac advance hooked up and see if that works. Are you sure counter clockwise is for less vac adv?
09-06-2012 02:49 PM
68NovaSS If you would do a search here, there are literally hundreds of threads in the database about timing, pinging, causes and cures.
09-06-2012 10:07 AM
sbnova I have 10-1 compression, stock heads, holley 750 dp, 514 lift cam.
09-06-2012 08:17 AM
67Mustang Al. AS ss said. Your compression ratio is the dictator for octane rating of the fuel required. You may need to up the octane to around 98+ and alter the ignition timing back until it stops pinging.
We ran 13 to 1 compression in a stroked BMW using ethanol and wrecked a set of JE pistons .
I may be wrong but i think 10.5 to 1 is the limit for 93 octane fuel.
Al
09-06-2012 07:59 AM
SSedan64 More Info needed, as much as possible:
Heads?
Compression?
Pistons?
09-06-2012 06:58 AM
sbnova
sbc pinging

HI my sbc 350/400 hp has a pinging problem. I currently have a mallory unilite distributor with vacum advance. I tried setting my total timing at 33,34,35 degrees and it did not help. I went back to base timing of 6,8, and 10 degrees and no change. The fuel has been changed to fresh 93 octane tried octane boost no good, I am thinking distributor I am currently trying the vacum advance adjustment by turning the allan key in the vacum advance canister counter clockwise to reduce the advance curve so far ng. does anyone have any suggestions? can the distributor be defective? should I try another maybe msd or pertronix? thanks for any help..

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.