Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> T-400 kickdown switch
User Name
Password
lost password?   |   register now

Thread: T-400 kickdown switch Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-12-2012 05:15 AM
krunch007
Quote:
Originally Posted by 327NUT View Post
If you decide to go with the Lokar unit you can find them on ebay for about $85.
So haw are these activated? By pushing or by pulling the cable? Was looking for a dagram on them but everthing I have found is pretty vauge.
09-12-2012 05:13 AM
krunch007
Quote:
Originally Posted by vinniekq2 View Post
theres no vacuum module on the transmission?
Yeah, There is a vacuum module on it now. Not sure if it correctly adjusted though. The trans seems to skip first when I am in D. But when I manually shift from 1st to second to third all goes well. Wasn't sure if the missing kickdown switch had something to do with this or not.
09-12-2012 12:23 AM
327NUT If you decide to go with the Lokar unit you can find them on ebay for about $85.
09-11-2012 11:55 PM
vinniekq2 theres no vacuum module on the transmission?
09-11-2012 08:51 PM
krunch007
T-400 kickdown switch

Hey everyone,
I have a TH400 that is missing the kickdown switch. A couple of questions. First can not having the kickdown switch hooked up cause the trans to go directly to second and bypass first? Or is this a valve module out of adjustment? Just seems as though I am not getting the take off response I have when I manually shift to first when taking off.
Next I see Lokar has a HI tech kickdown switch set up that mounts on the trans and has a cable running up to the carb to activate it. Has anyone used these? Are there any adjustments required to the switch itself? These are pretty pricey compared to the standard switch set up. Just looking to see if anyone thinks they are any better or if this merely for looks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.