Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Electrical help, please
User Name
Password
lost password?   |   register now

Thread: Electrical help, please Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-30-2012 08:37 PM
raj4851
thanks EOD guy & vicrod

Hey guys, thanks for the replies. I'm now making progress. Thanks again, Rod
09-28-2012 03:04 PM
vicrod The "I" terminal and wiring is not used on the HEI dist.
The Ford solenoid is not needed. Just something else to fail.
The Ford solenoid will shut off battery power to the starter. The alternator will need to be routed to the fuse block.

vicrod
09-28-2012 03:45 AM
EOD Guy If you are using the ford sol to cut off pwr from the battery etc.... I'd hook the ing wire from the new wiring harness to the batt terminal on the dizzy and not use the "I" terminal on the ford sol. If you run it thru the "I" terminal..... just one more problem area that you don't need.

But yes it will work.
09-27-2012 09:15 PM
raj4851
Electrical help, please

I am wiring my '39 Ford tudor with a Gearhead Enterprises wiring harness. I am using a Ford solenoid with a trunk mounted battery. The diagrams I have seen say to run the "I" terminal of the solenoid to the coil and the "S" terminal to the ignition switch. I'm running an HEI distributor. Do I plug the wire from the "I" terminal into the distributor cap power wire plug in? Also, I plan to run the alternator output wire to the battery wire on the Chevy solenoid and I already attached the solenoid wire from the fuse box. Am I on the right track? Thanks in advance, Rod

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.