Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> T-350 Front Pump Seal
User Name
Password
lost password?   |   register now

Thread: T-350 Front Pump Seal Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-04-2012 11:31 AM
91CamaroDude It eventually came loose with no real issues, I wish I would have taken a picture of the tool my buddy used to put it back in. Essentially it is a metal cylinder sleeve that goes over the input shaft, and a few taps with a hammer on the back in and it sealed perfectly. Thanks your help!
09-29-2012 11:56 AM
joshp83 look at the bushing and converter hub also if u remove the pum theres a o ring and permatex the pump bolts
09-28-2012 07:19 PM
Ruthlessmr are you going to take the pump out?
either way i take a 1/2 inch straight blade screwdriver and hit the edge of the seat towards the stator shaft . You prob will have to hit about 1/4 of it in then it should loosen up
Loctite the seal in and grease the inner part
make sure the snout on the convertor is not wore or scratched
good luck
09-28-2012 06:46 PM
91CamaroDude
T-350 Front Pump Seal

Alright, I got the tranny out, and now am trying to replace the front pump seal, but it looks like the original one has been in there for decades, or someone globbed some sealant behind there... Needless to say its a PITA to get out & is starting to look somewhat finaggled. Without using a specific tool for pulling this off, would heat or anything help to pry it loose? Im using a jimmy and a long flat head and its not working all that well. Any help is appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.