Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Valve Covers
User Name
Password
lost password?   |   register now

Thread: Valve Covers Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-19-2012 01:56 PM
66GMC Good to hear!
10-18-2012 09:55 PM
LBL
Seems good

I put the valve covers back on with the baffles in them and replaced the generic PCV valve with one for the 351 Windsor and took the car for a ride on the highway and it seems like it's okay. There is no oil on the valve covers so I am thinking that it will be good. I am putting the car away for winter now but am optomistic that it will be good when I get it out in spring. Thanks for the advice.
10-14-2012 03:38 PM
ssmonty I know it somewhat dangerous, but after the engine is hot you might try chocking the wheels, have someone in the car that can hold the brake HARD while its in drive, and giving it a little throttle. Just for a look see. If dipstick is blowing out, remove the pcv temporaraly and try again. If it doesn't blow out you'll know the pcv set-up may be wrong, or just way too much blowby. Never tried it, but it might point you in the right direction?
If what I saw in your last picture of your engine is what your using now, IMO I would try a different PCV/breather set-up with a regular PCV valve with a larger diameter hose. If you don't have room for the spacer that 66GMC suggested, might try temporaraly using a vacuum port on the manifold(same as brake booster), but don't leave it on the same port as the booster for long, just for troubleshooting.
The pcv should be on the carb circuit for proper A/F ratio.IMO
FWIW
ssmonty
10-14-2012 03:20 PM
66GMC IMO, 10 psi signifies fairly significant wear, and is probably enough leakage to create positive pressure in the crankcase.

The baffles will likely help a lot. Like SSMonty said, check the PCV valve and make sure that the entire PCV system is set up correctly.

You need filtered air going in on one side of the engine and a PCV valve connected to manifold vacuum (quite often from a carb spacer plate on a Ford)
10-14-2012 03:03 PM
LBL
Pcv

the PCV valve is new and does rattle when I shake it so I beleive it's okay. I have the hose from it running to the front port of my carb ( Edelbrock). I also have the breather on the opposite valve cover vented into the bottom of the air breather. I am thinking that I am getting some oil pushed out the dipstick tube, but nothing shows up when it's idling , only after I've driven it for a while. Thanks for the reply.
10-14-2012 02:23 PM
ssmonty If your talking about the little sheild plate that is screwed into the cover under the PCV port on an Edlelbrock Elite valvecover, don't waste your time. I hate to say it, but its a poor design. You need some different valve covers with stock type baffles IMO.
I'm not familiar with much Ford stuff, but it sounds like your compression is ok, and a little blowby is normal.
As far as the oil on the wires, it could be from a bad valve cover gasket.
Just out of curiosity, where is the pcv vacuum side connected, and are you sure its the correct one for the set-up you have. Does it rattle easily when you shake it up & down?
ssmonty
10-14-2012 02:04 PM
LBL
Help

Can anyone help me out here ...Thanks
10-13-2012 08:28 PM
LBL
Wet Test

I found out how and did the wet test and the compression increased minimally from between 0 to 10 psi , nothing was any more than 10 psi difference. I really don't know that much about V8's but I am thinking that I don't need to pull the motor and rebore it with numbers like this . Am I correct or should I be thinking of boring it out. I haven't driven it since I changed the baffles so I can't say if that helped with the crankcase pressure or not. I'll be able to take it for a spin on Tuesday.
10-12-2012 08:49 PM
LBL
Test

I did a dry compression test and the cylinders are all between 145 and 160 with most being 150. The 'o' ring is good on the distributor and I put the proper baffles in the valve covers. To do the wet compression test, do I just put a squirt or 2 of oil in each cylinder just before doing the test again ?
10-08-2012 02:26 PM
66GMC The "China Wall" is kind of a nickname for the ribbed portion of the engine block, front and rear, that the intake manifold seals to.




Great Wall of China
10-08-2012 02:19 PM
LBL
I'll Check

Those things but what is a 'china wall' ?
10-08-2012 01:55 PM
66GMC
Quote:
Originally Posted by LBL View Post
Before I start pulling the engine, is there anything else I should consider other than blowby that might be creating too much crankcase pressure ?
Try doing a "wet" compression test first, and compare to the "dry" readings. That should give an indication as to how much is getting by the rings?

Definitely install the correct baffles, and inspect/replace the PCV valve (and filter, if equipped)

How about the "china wall" seal at the front of the intake?
Fords also use an o-ring to seal the distributor ... right?

Any oil leaks from the front of the engine will get blown all over the place by the fan.
10-08-2012 12:35 PM
LBL
First

Before I start pulling the engine, is there anything else I should consider other than blowby that might be creating too much crankcase pressure ?
10-08-2012 10:43 AM
LBL
Ya

That's kinda what I have been thinking, must be pushing some oil out the dipstick tube. It doesn't seem like too much crankcase pressure when it's sitting at idle but I guess once I start increasing the revs to drive it, it must increase the pressure. Looks like I'm pulling the motor out again and getting it bored out over the winter ...
10-07-2012 10:38 PM
WDCreech You apparently have too much pressure building in your crank case. Check to see if the PCV valve is clean and working.

Bill
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.