Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 4L60e Low Reverse Clutch
User Name
Password
lost password?   |   register now

Thread: 4L60e Low Reverse Clutch Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-13-2012 10:38 AM
abbazabba Oh yes yes! Yes sir that is installed correctly.

You scared me! I thought i forgot something.. already have the pump on.

Thanks for your help! (on the other thread too)
10-13-2012 10:36 AM
motosyco I guess I should have been more specific your rear roller is a sprag and where it indexes in the case there is a cushion spring that goes in the case first before your rear roller its kinda bent like a mishaped u
10-13-2012 10:14 AM
abbazabba Cushion spring on the sprag?

I have a sprag that installs into the low roller assm. with a snap ring on both sides. Could that spring be part of my new sprag?
10-13-2012 09:55 AM
motosyco run it and go just make sure you use cushion spring when you reinstall that sprag or you will take out the case
10-12-2012 01:44 PM
abbazabba I called monster trans and talked to there tech department. The guy says that this borg warner sprag is usually pretty tight and even the occasional squeaking noise I am hearing can be normal.

Does anyone object to this information??
10-11-2012 06:35 PM
abbazabba Crosley,

Are you saying that it should not be a problem? It should become more free spinning as it is run in the transmission?
10-11-2012 06:18 PM
Crosley new roller clutches are tight usually. Some tighter than others.

I check them bent springs and such and run em
10-11-2012 05:30 PM
abbazabba
Anybody anybody?

Any thoughts on this? I'm kind of stuck in limbo here since I can't continue my build.. any thoughts on this would be appreciated! Thanks
10-10-2012 08:04 PM
abbazabba
4L60e Low Reverse Clutch

98 k1500 4x4 350 with 4l60e

Rebuilding using monster transmissions ss kit for the 4l60e

4L60e Low Reverse Clutch Seems to be to tight when I turn to clockwise it does turn but I would think that it would be more smooth. It does not turn counter-clockwise.. which i do know is correct. Can anyone tell me if this is okay or what needs to be done to troubleshoot?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.