Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Duraspark module overheated and engine died
User Name
Password
lost password?   |   register now

Thread: Duraspark module overheated and engine died Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-01-2012 05:51 PM
Augusto PROBLEM SOLVED

the new coil works perfect, module stays cool, coil slightly warm as expected.

engine starts fine with the initial timing set at 20 degrees.

the TFI coil draws more current than the module can handle, that was the problem.

thanks for helping.

greetings from the middle of the earth.
10-29-2012 04:27 PM
farna The TFI coil requires a full 12V. With the older style coil you might be okay.
10-29-2012 12:11 PM
Augusto that's a pretty neat instalation of the GM module, nice job

I just installed a 1.6 ohmm resistor to the TFI coil, it started fine, neither the coil or the module overheated, but after 5 minutes or less, the resistor became very hot and the coil quit firing, seems like the resistor didn't like the coil, the voltage at the coil terminal "flashed" at something around 5 volts, and I say flashed because it actually did, couldn't get a constant reading at the + terminal of the coil, my meter is a top of the line OTC unit... was strange.

The module was cool.

I bougth a new coil, regular type, it's a universal New Era, square syle, looks similar to the GM coil, but this one came with an external resistor, I'm gonna hook it up and see what happens.

If this fails, I'll go with the GM module, I have used it here in the shop for years in all kind of cars, mostly Toyotas and Fiats, and works better than the expensive oem's, I have even used it once in a Suzuki Intruder motorcycle, instead of the CDI module, worked great, even with fixed timing, 'cos it can't handle that.

this afternoon I'll know what happens, I'll post my results.

thanks a lot for helping.
10-29-2012 10:00 AM
GREENBIRD56
Ford Module replacements

Augusto - Originally, I put the Duraspark II triggger assembly in the distributor of my Thunderbird and rigged it to run with the "blue" module. The best one I found was made by "Standard" - but it wouldn't handle a coil with a low OHM primary winding. Total primary plus the ballast had to be over 1.6 OHMs. So....I built this replacement that uses the GM four pin module and plugs into the Ford harness connectors...bolts in the same spot.


It doesn't have the 6 starting retard of the Ford style unit - but will handle some really powerful coils (low primary OHMs) without a ballast resistor. It will run a TFI type coil virtually forever. I wanted a hotter coil - factory type part - so I wasn't paying for a "name brand" - and found the GM "E-core" from a small V6 pickup worked like a charm. it is roughly .5 OHMs primary.


If you hook up an old fashioned "dwell meter" to this outfit, you will find that the HEI module drives the dwell down to about 15 at idle (keeps the coil AMPs and heat down) - and then jacks it up to over 35 at elevated RPM. So it is similar in dwell to an old dual point distributor at the high end - but can use a modern coil with way more jolt than points could ever tolerate. The GM replacement coil shown here has the same operating specs as an MSD "StreetFire" E-core coil - you can get them brand new from the internet for about $10/$15 - and less at the salvage yard.
10-29-2012 08:54 AM
farna That's right, no way to get a good DS module. Ford stopped using them after 1985 (Duraspark I and II). If it has EFI of any kind it is a Duraspark III and uses an entirely different type of module. The DS III uses a TFI module and coil, entirely different from the previous models. What you mostly see now is the DS II. DS I was used 73-75 and had a conventional cap and wires, DS II introduced the big cap and positive locking wires. The control boxes for the two are slightly different.

See Duraspark Upgrade
The last thing mentioned in this article is a new performance module that plugs into the existing DS II distributor. You can use that instead of the HEI module if you want. I don't know if the HEI module adjusts timing for easier starts or not, but I wouldn't be surprised if it did.

You might be able to get a better Duraspark module from Chrysler, or all places! The Jeep Grand Wagoneer used Duraspark II through 1991. Try a module from the local Jeep dealer. Of course they may just repackage an aftermarket box now, who knows?
10-28-2012 09:51 PM
Augusto there's like a million sites about going HEI in Duraspark systems, most of them are Jeeps, is it that there's no way to get a good DS module anymore?

I have a green DS Motorcraft module, but seems like I should use the blue or the HEI, no more.
10-28-2012 08:44 PM
GREENBIRD56
Ballast Resistor

Augusto - It most likely has to do with the quality of the replacement Duraspark II Module you are having to use. Yes - using a ballast resistor will work wonders on lowering the load on the transistor. On the typical OEM set-up for a Duraspark II, there was a ballast resistor wire of about 1.4 OHMs and the orignal coils were 2.0 or over - total resistance was way different than a TFI coil alone. The replacement module you were using most likely would have to have that sort of total resistance in order to survive with reliability.

This diagram shows a HOT ignition that uses the GM / HEI type of "four pin" module - and a later very low OHM GM coil. It works because the GM module shortens the "dwell" and regulates current to protect its grounding transistor. The coil looks very much like the TFI coil - but has less than 1/2 the OHMs. The GM coil will melt a Ford type module in a very short time - works great with the HEI four pin.
10-28-2012 08:28 PM
Augusto basically I think that the lack of resistor raises the current too much for the transistors to handle, this overheats the module, so I'm adding the resistor to see how it works.

If it still gives me trouble I'll do the HEI conversion.

too bad, because I really like the ability to retard the ignition while crankin that the duraspark module has.

The local ford dealer does not have them modules anymore, is the same in the USA? why?

and also why no performance brand name has a duraspark module?

are all ford performance cars using MSD or the like ignitions?
10-28-2012 07:41 AM
timothale
ford overheat

Ford ignition modules are sensitive to heat. One of the guys I worked with used to drive a brand new truck off the assembly line every day as part of Quality evaluation. During the summer he would stop at a fast food place half way home and get a cup of ice to cool it down just to get home. Ford used to have an air condition relay and circuit breaker on full sized cars up under the glovebox. In the summer when the inside of the car would heat up. the ac would run for 2 or 3 minutes before it would kick the hot breaker.
10-28-2012 05:52 AM
Irelands child Agusto - this is the way the DuraSpark is set up with the HEI module as suggested by Farna plus GOOD parts are way more available these days

Dirt cheap Ignition

I haven't tried that set up, but have been assured by a couple guys that it works well (I gone to full MSD ignition)
10-27-2012 11:43 PM
farna Typically, if a coil has a ballast resistor it will need a ballast resistor no matter what type of ignition is used, points or electronic. The TFI coil shouldn't need a resistor though. Sounds like you either have something wired wrong or just a bad ignition module (Duraspark box). The TFI coil will work with the standard Duraspark box. A lot of people use the GM HEI ignition module with the Duraspark distributor. Search Google for "Duraspark with GM HEI module" and you'll come up with several sites. The GM module is just higher quality than the aftermarket Duraspark boxes. Ford quit making them long ago!
10-27-2012 10:09 PM
Augusto
Duraspark module overheated and engine died

My points to electronic conversion suffered this problem, just started, set the timing and was idling, like ten minutes or more, suddendly the engine died, no spark, inmediately I noticed the module was very hot, so was the ignition coil, it's a TFI "square" coil from a 1987 Econoline I6, the module is a new Spartan brand name blue module.

I cooled the module with a wet rag and the engine came back to life.

I hooked up the module and the coil with full 12V, no ballast resistance for the coil, I'm feeling this is the problem, maybe this coil needed a ballast resistor ?

I have this 1.6 ohmm ballast, if I install this, will the coil run cooler and put less strain in the module, so it won't overheat? or the TFI coil is wrong for the Duraspark ? it was running fine with the points, never missed a beat, never tested how hot it run with the points though, but I did used the ballast resistor with the points.

thanks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.