Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 1994 5.7 TBI/ Vortec/ Intake/ EGR Question
User Name
Password
lost password?   |   register now

Thread: 1994 5.7 TBI/ Vortec/ Intake/ EGR Question Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-05-2012 06:45 PM
Pre-Tuner I don't think that one will work either. It has one inlet and two outlets. You would need something with one inlet, one outlet, and a return port.
11-05-2012 03:49 PM
allansmith859 I couldn make up my mind but think it would be a better option
11-05-2012 08:01 AM
Jim Rockford ohh didn't see you where going with a carb.
11-04-2012 10:14 PM
allansmith859 http://www.jegs.com/i/JEGS-Performan...15912/10002/-1

Looking at the pictures on it the bottom is in and both sides are out. The line from my fuel filter will go into the bottom. Then ill have a hose from the left side go to the inlet on carb. Then ill have a hose coming from the outlet on carb back to the right side of the regulator. Thats the way im understanding it if im correct??????????? I guess I could start a new thread, I know im asking alot
11-04-2012 10:05 PM
Pre-Tuner I don't think the regulator will work for a couple of reasons. The first is that it isn't adjustable to what you will need. You will need 5-7psi and that one only goes to 4, so you could run out of fuel at wide open throttle. The other problem is that it isn't a bypass regulator. I could be wrong, but you have an EFI fuel pump that is capable of a lot higher pressures, so I think you may need a return style regulator. Maybe someone else could chime in here.

Mine has three connections. One from the pump (filter), one to the return line, and one to the carb.

The other stuff looks good. The one connector says GM TBI, so I hope that is the one that I used for the filter. The hardline one should work great. I would either get two of those hoses or a longer one that you can cut.
11-04-2012 09:52 PM
allansmith859 Ok check out these parts. Will this be what I need?? Also do I need to get two of the braided hoses. Does one hose come from the filter to the regulator and from the regulator to the inlet. Then what about the return line. Will I leave that how it is and screw that into the carb?

Holley 12-804 Holley Fuel Pressure Regulators

JEGS Performance Products 103106 JEGS Fuel Injection Fittings

JEGS Performance Products 110551 JEGS Hard-Line AN Adapter Fittings

Spectre 29404 Spectre Steel-Flex Hose
11-04-2012 08:39 PM
Pre-Tuner I had one that I was using with my TBI setup because it was vacuum referenced. It is way overkill for what you need. It is an Aeromotive universal bypass regulator. I know there are others that will work but I don't know what they are.

As for the fittings, I "think" I found exactly what I am using. I went through some receipts and came up with a summit racing 2200077, -6, 3/8 male hard tube fitting (for return line), and an Earl's 991955, -6 to 16mm x 1.5mm fitting (connects directly to the fuel filter). Where I picked up the connection was at the filter and then ran braided lines to the regulator.
11-04-2012 08:06 PM
allansmith859 Ya I dont know I figured it was a fuel line. It reminded me of the fuel line on the front of the quadrajets. As far as a regulator do you remember which one you have and where you got it. And the fuel lines where can I get the adaptors or do you recomend just running new fuel lines. But are they pre bent already or how did you come up with this setup??
11-04-2012 07:56 PM
Pre-Tuner Oh ya, you will need a regulator also. I am using a return style regulator and it works fine. There are adapters you can buy to connect to the pipes at the TBI, but I didn't like that. I ran a new line from the filter to the regulator and another from the return pipe next to the filter to the regulator.

There are only two fuel lines. One is pressure from the pump and the other is for the fuel return back to the tank. Both are on the back of the TBI, so I'm not sure what the one on the front is for. Are you sure it's for fuel???

You're driving it on the street, so you would want vacuum secondaries. That will keep them closed unless you are really on it. Mechanical secondaries are for racing. They open and let more air (and fuel) through the carb when needed.
11-04-2012 07:46 PM
allansmith859 Ok sounds good. the noly other concern I have is there are three fuel line. one on the front of the tbi and two on the back. From what I was told two are return lines and I could not use one. Would these fuel lines screw right into a carb. Also why would I need vaccum secondaries. Just curious what that means
11-04-2012 06:58 PM
Pre-Tuner You won't use the computer at all. The extra info I was giving you about it was just in case you wanted to work with what you have you would have the info. The older HEI distributor is exactly what you will use. You probably want a 650 carb, vacuum secondaries, electric choke.
11-04-2012 06:04 PM
allansmith859 Ok so if I make this a carb setup will I still be using the computer. I have the intake and a disributor but no carb yet. And that would be an HEI distributor like the old style right.

Man I appreciate your help.
11-04-2012 05:57 PM
Pre-Tuner It's not crazy because lots of people do it. I did it. You need a carb, distributor, an intake manifold, and need to do a little bit of wiring. It really isn't a big deal. I went through and disassembled the wire harness and removed the wires to sensors/actuators/injectors that I wouldn't need anymore to clean things up. Outside of removing wiring and connectors, you have to wire the fuel pump relay different and will need to wire the distributor different, but the wires are already there. You will also need to wire the choke if you have a carb with an electric choke. It needs to be an ignition wire, but NOT the ignition wire to the distributor. I ran a separate relay for the choke.

The ECM is behind the glove box and the chip would be behind the access panel that should have two screws holding in on. I believe it sits on top of the HVAC box.

If the O2 sensor is welded to the exhaust it is junk. If you were going to use it, take it to an exhaust shop and have them cut it out and weld a bung in so you can use your new sensor. It shouldn't cost much. With O2 sensors, you cannot cut the wires because they won't work right afterwards.

It's probably running like a champ because the chip was tuned to run in open loop. If you change the heads it probably won't run that good anymore, expecially with no O2 sensor to provide feedback for fuel trim.
11-04-2012 05:41 PM
allansmith859 Ok let me explain to you about the truck when I got it. I bought the truck cauese it had 150000 mile on it and got it for cheap. Figured it would be a good work/farm truck since I haul lots of fire wood. When I got it the fuel milage did suck very bad. I filled the tank up and got 70 miles. Ya crazy right. I had a brand new cam I bought in Feb. that was for low end torque so I decide to use this cam in this truck. I put the cam in put the engine back together and it still sucked the gas down. Come to find out the timing was off so once I got that corrected I get 300 miles per full tank of gas. Thats fine with me, its a truck. The guy who had it before the guy I got it from had headers on the truck. The guy I bought it from had factory exhaust put back on it. The exhaust he had put on it had an o2 sensor in it but it doesnt have the right plug to plug in to the truck so the connecotr is just hangin there. The correct o2 sensor was plugged into the truck and just hanging there. I took the correct one and stuck it in the glove box. The one that is in the exhaust (the one with the wrong connector) is welded on the exhaust. (stupid right). So I was going to cut both connectors off both o2 sensors and put the correct connector on the sensor thats stuck in my exhaust right now so it would be functioning. But I havent because the truck runs great right now. As I said in my last post I would like to switch to carb. I might even get better fuel milage, maybe not but besides I know I would get some power thats being held back. As far as I know I would have to change The distributor but other than that I dont know. Know I guess If I could get by with the TBI I would but a carb does sound like a better route. As far as what you guys are tellin me it doesnt make sense cause I know I have no egr and no o2 sensor but my truck runs like a charm. I have had my glove box out before but never paid attention to any stickers on it. I just thought it all looked normal. This is kinda strange. But what did u have to do to put a carb on your tbi setup.
11-04-2012 01:15 PM
LATECH A check engine light will set for the EGR under these conditions

Closed loop operation
Continuous Road speed of XX miles an hour or more for more than X minutes

Not certain of exact time verses road speed, but it is necessary.

When driving, the ECM checks the EGR by closing the valve and measuring the change across the MAP sensor vacuum value.
It checks it after closed loop is achieved, and road speed is over a certain speed- and time elapsed value.Reason being it is assumed after X amount of minutes that the trip will be an extended one, long enough to sustain conditions for testing.
I would bet if you drove it down the highway at 35-55, steady cruise, for 10-15 minutes, the EGR code would set.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.