Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 91 Chevy 2500 4x4 Transmission questions
User Name
Password
lost password?   |   register now

Thread: 91 Chevy 2500 4x4 Transmission questions Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-06-2012 04:37 PM
TexasT You need to make a call to Phoenix Transmission in Weatherford. They are experts on the 700r4/4l60e.

Phoenix Transmission Products | 700R4 - TH-2004R - TH-350 - 4L80E - High Performance Transmission Products

They have always taken care of me.
11-06-2012 03:29 PM
YOUNGSTER27 Is there a different trans I could put in it? Or am I stuck with the 700r4? The rebuild happened while I was traveling. Was wanting to "beef it up" a bit before that happened. A quick rebuild and I was ok for a lil. What can I do?
11-06-2012 02:43 PM
delawarebill
tranny prob's

u really should be talking to the shop that did the repairs.. problems in a month, are a problem for the shop, not u...
11-06-2012 01:45 PM
YOUNGSTER27
91 Chevy 2500 4x4 Transmission questions

I have a 91 Chevy 2500 4x4. It's got a 6" lift with 35" tires. I am still running the 700r4 in it. I had it rebuilt about a month ago should I be having problems with it already? If not what can I do to better the drive-ability of my trans? I'm new to dealing with trans. but more than willing to learn.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.