Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Ford alternaor not charging
User Name
Password
lost password?   |   register now

Thread: Ford alternaor not charging Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-11-2012 02:00 PM
mustang 671 thanks for the links. and they are alot easier to follow in the link you sent. funny though as i have the diagram in the workshop manual the same and thought i followed it . well looks like im going back and checking which goes where.

thanks for your help guys
11-11-2012 12:14 PM
Joe G Here's a link to the factory wiring diagram for a '67 Mustang. This diagram shows the ignition and starting circuits as well as the charging system. In the attached diagram, I simplified the original to show only the charging system.

Hope this helps....

Joe
11-11-2012 10:31 AM
66GMC The wiring colors may vary from year-to-year, but that Ford charging system used the same external regulator for many years. Some of the early versions used contact points inside, but the replacement electronic versions are completely "backward compatable".

I just posted this in a thread a few days ago:
http://www.hotrodders.com/forum/hei-...ml#post1608152

The wiring diagram there is from a 1979 F150 ... but it's very typical.
11-11-2012 10:19 AM
mustang 671 had a fiddle around today and still cant get it charging. any electrical guru's out there to guide me on whats wrong ?
11-10-2012 02:30 PM
mustang 671
Ford alternaor not charging

hi all . i have done a something silly .

all my wiring hadnt been cleaned up and now that i have got my engine running i decided to clean up all the wiring and also tape it all up and clip to the chassis and tidy it all . during this some of the wiring needed to be sorted out and untangled. so i did that. and then got in a pickle and had to refer to the owners manual of my 1967 ford mustang and find which wires were to go to the regulator . it now doesnt charge !! doh .

does anyone know and easy way to fix this without undoing hours of work ? ie is there a simple diagram i can follow from the alternaor to the "seperate"regulator to get it charging . its not the connections as i have checked all of them and all the fuses are ok so its all looped in and should be charging.

what a numpty

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.