Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> LS 2006 5.3 Wiring harness
User Name
Password
lost password?   |   register now

Thread: LS 2006 5.3 Wiring harness Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-30-2012 11:46 PM
pshell Found some pictures. The harness is not in split loom, so it looks unfinished. I wanted to drive it around for a while before I put it back into the split loom.


Showing computer mounting:


I also used the late model radiator and pressure tank. The following pictures show how I modified the core support to do it:





Those brackets are from the stock truck, I flipped them over and swapped sides. I test fitted the radiator then welded them on.

I think you'll find it's been a constant evolution with these trucks. Things just kind of evolved and the placement of components is close if not the same.

Hope it all helps.
11-30-2012 11:29 PM
pshell Solid axle, I removed the harness from the engine and laid it out on the garage floor. You should have two, rather large computer connectors. You start at those ends, mine were labeled and colored red and blue. I think you may have a different color, depending on the year. Get the same year harness and type when you visit the junk yard. If you don't you could end up replacing connectors at the injectors and I think some sensors are different based on year.
Since you are retaining the 4l60e, you will use a lot of the connectors I pulled out. I think you will retain most, except for the evac and second set of O2 sensors. I guess that depends on what you plan to do.
Back to the question, you will remove the split loom and remove the factory electrical wrap. Keep it all together when your pulling the wires. You don't want it to come apart and lose it's shape. Remove what you came to remove and tape it back up.
Vortec 4.8/5.3/6.0 Wiring Harness Info is full of information for modifying your own harness. That is the site I went to for the pinout of what I needed to remove. You just need to throughly understand what your doing, just not ripping wires out of the harness and expecting it to work.
I don't know how many are still in the connector that run back to the computer, but it was plenty. It will be lot's more in your case as your retaining the transmission; I bolted it to my SM465.
My truck came equipped with dual batteries, so I have a tray on the drivers and passenger sides of the truck. The late model SUV's/trucks mount the computer on the drivers side with a little plastic tray off or near the battery tray. I went to the wrecking yard and got that little tray, welded some studs to my drivers side battery tray, and mounted the computer in basically the same location GM mounts it. When you are done modifying your harness you will have three wires coming out of it a couple of feet from the computer. You will need to hook up a relay to the switched 12v, fuse the constant (and maybe the relay) and provide a ground. There will be other wires coming from the computer, as the printout will show. Most important is the fuel pump wire. That needs run to another relay as well. I'll dig around for some pictures.
11-30-2012 07:05 PM
302 Z28 I would vist many salvage yards before I spent a grand on an aftermarket harness.

Vince
11-30-2012 03:51 PM
solidaxel OK, so which end did you start at?
So did you start at the computer connector pin cut the wire and follow it to the end of the sensor?
How many wires were remaining in the connector when you finished?
Where did you mount the computer?
Do you have any finished pics of your engine compartment?
11-29-2012 11:51 PM
pshell I registered to reply to this, great forum BTW.

I completed a 5.3 swap into my 1981 GMC K2500 about a month ago. I used Hooker adapter plates from Speedway motors. You can buy them with different engine offsets or stock. I used the stock location and it worked great. Hooker sends the plates with all the needed hardware.

I looked at pre-made swap harnesses, and I would recommend that you just do your own. I spent about 1.5 hours in the garage modifying the stock GM harness to suit my needs. The only thing that tripped me up was the VSS signal in and out. One comes from the trans and one goes to the instrument cluster (in the stock configuration). I had it wired backwards and the engine didn't know it was moving, leading to some drivability problems when I pushed in the clutch.
There are a couple of reason I would recommend you modify a stock harness:

- you will end up doing the cutting or adding to a painless, or other aftermarket harness, when you want to add or delete something in the engine harness IE: 3 wire temp sensor for your stock gauges

- the stock harness is built with very high quality wire and is a fraction of the cost of the Painless harness

- stock harness already has the shape of the engine and the split loom installed and sized correctly

Once you remove what you don't need, it becomes a 3 wire hook-up to make it run. That's a little misleading, as you'll need to wire in all your gauges, cruise stuff(maybe), VSS, and a couple more things I'm forgetting. It will run when you supply ground, constant +12v and ignition switched (while cranking, HEI wire works well for this) +12v.

I ditched the A/C, so I can't help you with that. I had planned on reworking the frame in that area if I were to keep it. It's cheaper, in my minds eye, to modify the frame rather than buy an aftermarket setup. I think it would also be pretty easy to build a mount for the A/C that moved it up and away from the frame. The A/C on my engine had it's own belt/tensioner so it should be easier to build something that would work well.

Just some random thoughts, hope it helps.
11-21-2012 03:45 AM
cobalt327 When I was looking at a 6.0L/4L60E/drive by wire throttle for my wagon, I found the harness I wanted- but it was nearly a grand! Painless p/n 60221- NOT AT ALL painless!!! IIRC the same harness works on the 5.3 and 4.8, but check if interested.
11-20-2012 08:40 PM
solidaxel
LS 2006 5.3 Wiring harness

I am getting ready to install a 5.3 in my 78 Chevy pick up and am in need of wiring harness, motor mounts and A/C relocate bracket.
Who has the simple effective harness for the engine and 4L60E transmission with a drive by wire foot feed

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.