Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> ring reuse
User Name
Password
lost password?   |   register now

Thread: ring reuse Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-01-2012 11:57 PM
cr480r Thanks for the opinions guys. Think I am going to chance it. The TS1's are $250 dollars these days, these are already gapped and i am just not ready to give up on them yet. I knew from the start there was some risk of them not sealing again and i am ok with that. The local racers i spoke with just made it seem like there was little to no chance of success so I felt the need to seek a few more opinions. The debris was only from one lobe and it was caught early. Basically i just pulled it apart to clean the block so that nothing gets in the new lifters (went to hydraulic rollers).. my bearings were actually pretty good, and i might even be tempted to use them again if i hadnt already bought the parts and have it on the stand.. I will say I am now a firm believer of using magnets on the walls of the pan sump, eliminating the bypass in the adapter, and using 1794 filters. My oil drained out fairly clean, and the magnets and filter were definately working.
12-01-2012 07:54 PM
vinniekq2 I ve reused rings a few times,not on an engine that took damage.how much is a set of rings and your time worth? try it?
12-01-2012 07:20 PM
1Gary Got mixed feelings about this one.I hear ya about the leakdown test being cold 5%.Btw-thumbs up for doing the leaddown.Yet they where exposed to the fragments of the failed lifters too. Got me wondering what a leakdown would be hot. I guess you could get lucky.Maybe you wait until after the holiday's costs and then get back to it with a fresh set of rings.It's a $100.00 save bet.
12-01-2012 06:41 PM
timothale
reuse?

years ago when my brother was doing a lot of racing he would pull the engine apart every couple months clean up everything remove any carbon, polish the valves. He would just do a glaze breaker lightly on the cylinder walls and reuse the rings, back to the same bores.
12-01-2012 06:08 PM
BOBCRMAN@aol.com If you replace pistons/rings in the same bore they came from. The rings will be alright to re-use. They will seal up and give no problems. I've seen it done dozens of times..
12-01-2012 05:18 PM
hcompton The iron rings have surly seated in by now. You got good chance of them working but might not be worth the issue if it needs to last. I would just get a new set and be done with it.
12-01-2012 04:53 PM
cr480r they are total seal brand with gapless 2nd. TS1. Rings are still on the pistons & the rods are marked.
12-01-2012 04:48 PM
hcompton
Quote:
Originally Posted by cr480r View Post
Recently had a cam lobe failure on a flat tappet. I tore the engine down to setup my new valve train, and I disassembled the short block to clean the components and replace the bearings and pump. My engine had under 1000 miles, and now i have a couple people telling me i cannot reuse my rings since i removed them from the bores.. They claim the rings have hardened with use and may crack.. They are total seal TS1'S and I really dont want to replace them with such little use. They had under 5% leakage(cold), Its very close to christmas, and i just spent a bunch on a HYD roller setup. What do you guys think?
Do you have the pistons marked with the rings still installed. They need to go back in tje same cylinder and normally you dont put them back in. But at low miles ppl have done it. It may not seal up and smoke if you do not replace them. But if you do and it does not smok after a few miles then your fine. Just taking a chance at needing to replace them early.

What type of rings are they?
12-01-2012 03:51 PM
cr480r
ring reuse

Recently had a cam lobe failure on a flat tappet. I tore the engine down to setup my new valve train, and I disassembled the short block to clean the components and replace the bearings and pump. My engine had under 1000 miles, and now i have a couple people telling me i cannot reuse my rings since i removed them from the bores.. They claim the rings have hardened with use and may crack.. They are total seal TS1'S and I really dont want to replace them with such little use. They had under 5% leakage(cold), Its very close to christmas, and i just spent a bunch on a HYD roller setup. What do you guys think?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.