Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> General Rodding Tech> First timer. Hello to all. My name is RedGeese and I have a 1985 corvette
User Name
Password
lost password?   |   register now

Thread: First timer. Hello to all. My name is RedGeese and I have a 1985 corvette Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-10-2013 06:28 AM
RedGeese Gentlemen,
Thank you all for your input. I apologize for not responding sooner as I've been out of town of late. The dry gas has been suggested to me by others as well. That willl be my first action this weekend. The fuel filter next, and if need be, the fuel pump last. Logical approach............thanks again.
12-06-2012 03:31 AM
Jimbo17
Not sure what part of the country you live in.

First thing I would do is start with the simple things.

Purchase two cans of dry gas and add them to the fuel.

If that does not correct the problem change the fuel filter.

If the problem precess I would start looking at the fuel pump to make sure you have enough fuel pressure.

To me it sounds like a fuel system problem.

There is also a chance you have an intermittent electric problem which good be a number of different issues starting with the battery.

Start with the simple things first!!!

Jimbo
12-05-2012 06:47 PM
tnovot I vote for the fuel filter. I think it's mounted along the inner frame rail on passenger side. If it hasn't been changed in a while, you probably could use a new one regardless. It is lower than the fuel tank with no way to isolate it so have the new one ready when you remove the old.
Terry
12-04-2012 04:46 PM
delawarebill
sputter'n

now sure how to solve your problem.. but unless u got a bad fuse panel, i doubt it's a fuse.. for when they go, there dead..
12-04-2012 04:08 PM
RedGeese
First timer. Hello to all. My name is RedGeese and I have a 1985 corvette

Original owner, last year put quite a bit into restoration. Car has run flawlessly until last week. Drove it for about one hour, stopped for about three hours before getting back on road again. When I got to about 55 mph, felt sputtering. First thing that came to mind, bad gas? Filled up day before but why not a problem sooner? Sputtered at less than 55 into town/ my house not before having to pull over a couple times, car stalled but started immediately. I'm no mechanic but first thoughts 1) bad fuel 2)bad fuel filter 3) clogged injector (tuned port injection system). My friend says it sound potentially electrical to him. The fuse panel has two fuses for electronic fuel injector noted on it. Possibility? Any advice or point me in the right direction would be much appreciated

Regards

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.