Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> tuning edelbrock carbs
User Name
Password
lost password?   |   register now

Thread: tuning edelbrock carbs Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-31-2002 02:20 PM
dmorris1200 Sounds like she may be running lean and the added load when in gear is bringing the idle down. Not for nothing but I recently bought an Edelbrock carb for my stang. Right out of the box the float was sticking, she stumbled on hard lefts and had a dead spot off the line. I took it off, put it back in the box, and made the store take it back. I opted to pay the extra and got a Holley Street Avenger instead. I've used nothing but Holleys for twenty years and I guess I'll be using them for the future as well. I'm going to try and post a shot of the new carb in my photo album, I like the features of the Avenger carb. Tunable secondaries and no more power valve blow-outs. Good luck with yours, I would start with richenning her up a bit and see what she does, recheck timing, and make sure there's no vacuum leaks. See if you can improve it by adjusting the air/fuel screws on the front of the carb before you go rejetting.
07-31-2002 01:43 PM
4 Jaw Chuck Sounds like timing but could be a combination of carb tuning/vacuum leaks/timing. I would check the timing first and then look for any vacuum leaks. How is your idle mixture set?
07-31-2002 07:10 AM
1969cutlass
tuning edelbrock carbs

I recently swapped my stock manifold/ and q-jet car in favor of an edelbrock RPM manifold and 750cfm carb. My engine is a mild performance about 330hp from an oldsmobile 350. and i was having trouble with the idle i had to crank the idle up other wise it would die while it was in park but driving it in gear it rumbles down REALLY low. is it a vacum problem and messes with my metering rods or is it the jetting?
please email with any answers

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.