Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 671 Blower doing my head in and not even set up yet!
User Name
Password
lost password?   |   register now

Thread: 671 Blower doing my head in and not even set up yet! Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-26-2013 06:34 PM
chevyshuffler Wow thanks for the replies... Really appreciate it. Damn i never thought of that liquid whatever it is expanding with heat and steam when she warms up. Il order some new plugs then, i hate working with ali, especially on something like a blower rotor. It didnt come with any of the drive... I spun her with my fingers after taking it out of the packaging to see if everything was ok, everything looks great on it but you can hear the liquid trickling from lobe to lobe, sounds like quite a bit too. Came with front case end (standard polished GMC and heat sinked FOX engineering rear bearing cover which il have to machine down so rotor arm will fit behind. All polished so effort has been made on it on its rebuild... You would think!!! :S
Ahh here go's then ... Blower strip down for the first time!!!
01-25-2013 09:59 AM
1932bantam thats true anything possible in the hotrod world
01-25-2013 03:37 AM
cobalt327 I'm thinking along the lines of the plugs not sealing tightly and the rotors being submerged in a cleaning tank, letting the liquid get in past the plugs. But that's just a WAG.
01-25-2013 12:31 AM
1932bantam kind of weird how fluid would of stayed in rotors and put plugs in, when you would have them vertical , is this complete with a drive ? if so they could of put grease in it already? long set of feeler guages come in handy .011 down the middle and pull them up is usually good
01-24-2013 01:13 PM
cobalt327
Quote:
Originally Posted by chevyshuffler View Post
Thanks... Ok il have a go at it. How easy do you think it is to remove the plugs? And are the reusable? Why on earth would a guy building blowers re build a charger with cleaning fluid still in the rotors. If this is the case im starting to get second thoughts on the unit itself. Ohhh never rebuilt a blower before. Hope its doable!
The plugs won't be reused. No worries- they're cheap. Click on image below for more info.



Cleaning fluid being left in the rotors is just an idea, there could be some other reason. And how that reflects on the workmanship that has gone into this blower is debatable. But the main point it there's no legit reason for fluid to be there, and it should be removed- the rotors become hot in use, the pressure could cause a plug to pop out, and it affects the balance.

I would remove them w/a slide hammer using a self-tapping screw end on it. Drill the plug, thread on the puller and remove. Only need to remove the plugs from one end of each rotor.
01-24-2013 10:07 AM
chevyshuffler Thanks... Ok il have a go at it. How easy do you think it is to remove the plugs? And are the reusable? Why on earth would a guy building blowers re build a charger with cleaning fluid still in the rotors. If this is the case im starting to get second thoughts on the unit itself. Ohhh never rebuilt a blower before. Hope its doable!
01-23-2013 04:57 PM
cobalt327
Quote:
Originally Posted by chevyshuffler View Post
Thanks buddy... I had a look at that link, makes good reading! The guy i brought it from said he rebuilt it for a soldier out in iraq who wanted a project camaro but after being posted away for long periods on end said he might as well sell it.
Being an engineer i know how to set clearance's etc but never done a blower. We have always sent failed blowers away to be re-stripped and rebuilt or junked them if really bad. Just kept to my hemi and chevy rebuilds.
Ive never come up with this before but do i drain it? Is it there for a reason?
But yeah its going to be on my mind forever if i dont do anything about it! Think its very odd!
Thanks again!
Chances are the rotors got liquid in them when they were cleaned. When you remove the rotor end plugs, any liquid inside can be removed. And I would recommend you drain any liquid that's in them.
01-23-2013 04:16 PM
chevyshuffler Thanks buddy... I had a look at that link, makes good reading! The guy i brought it from said he rebuilt it for a soldier out in iraq who wanted a project camaro but after being posted away for long periods on end said he might as well sell it.
Being an engineer i know how to set clearance's etc but never done a blower. We have always sent failed blowers away to be re-stripped and rebuilt or junked them if really bad. Just kept to my hemi and chevy rebuilds.
Ive never come up with this before but do i drain it? Is it there for a reason?
But yeah its going to be on my mind forever if i dont do anything about it! Think its very odd!
Thanks again!
01-23-2013 03:56 PM
techinspector1
Quote:
Originally Posted by chevyshuffler View Post
its begining to play on my mind weather to fit n run or strip!
It will be on your mind for the rest of your life if you're anything like me. I call such things "a loose thread", as in clothing.
As far as setting it up after disassembly, a quick search on the web revealed this post from the H.A.M.B.
tech week 6-71 Blower rebuild - THE H.A.M.B.
Actually, unless you put it together and clearance it yourself, you have no idea that the current setup is correct or not.
01-23-2013 02:42 PM
chevyshuffler
671 Blower doing my head in and not even set up yet!

Hi all! Well its been a while since ive been on here, what with moving to the UK n getting set back up! But im not really a computer wiz so here gos!...

Ive just brought what i was told to be a good 671 blower... Now after donkey's years working with blowers... Top fuel dragsters etc ive really only worked with teflon stripped ones that were brand new and not really done the whole pro street project for myself... But this little problem is niggling me...

I unpacked the unit to see it spotless, its a recon gmc unit... Inside, rotors, gears all clean apart from red grease on the mesh. Over all good with very minor scores, rotors turn free with no grates but a funny noise. Sounds like the rotors have some kind of fluid in them... I can hear it trickling around or more like a very quiet slosh. Now... Nowhere on land or net sais anything about a fluid or some kind of liquid in the rotors itself. Now what is it? N if its not meant to be in there then do i risk stripping down n re gauging myself or just leave it in there? At first i thought it maybe some kind of attempt of balancing or mild harmonic type? Or cooling... But now such the vagueness and no info at all its begining to play on my mind weather to fit n run or strip!

Please help? Thanks!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.