Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 700r4 won't downshift- never has
User Name
Password
lost password?   |   register now

Thread: 700r4 won't downshift- never has Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-29-2013 06:38 AM
joshp83 you shouldnt have to let up on it sounds like the cable is not adjusted correctly also with out cleaning the cooler the valves in the valvebody can stick u would also need a governer from a gas powered truck to make the wot shift point correct yo may or may not have done internal damage
01-28-2013 06:03 PM
Wrenchy No i didn't. Would a shift kit help? or does it need deeper recalibration? It shifts fine under a normal take off. 3/4 throttle or more and I need to let off to keep it from slipping during 2-3 and 3-4. And have to downshift manually. I've run it this way probably 10-15K miles. Where do i find information on what to change on this Transmission to get it to work on my 350? Thanks
01-28-2013 07:03 AM
joshp83 the 6.2 has diffrent caibration then a 305 or 350 but should down shift when floored did you flush the cooler line when u replaced the trans
01-28-2013 06:55 AM
Wrenchy
700r4 won't downshift- never has

I have a 700r4 out of an 87 chevy 6.2 diesal van installed on my 72 chevy c10 350ci. The trans worked fine in the van but it slips on heavy acceleration between shifts and will never downshift even at WOT. Its done this since i put the trans in and the previous 700r4 i had in it did the same. Something isn't adjusted right and maybe i ruined it already. Any ideas? I adjusted the TV to every position imaginable, and i fixed the bell crank for the right geometry according to GM specs. I'm using the torque converter that came with the old trans... the one that quit. the diesal one was different. Is the trans built for the diesal and need like a different valve body for my 350 maybe? What do u think?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.