Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> 454 race build
User Name
Password
lost password?   |   register now

Thread: 454 race build Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-28-2013 08:38 PM
vinniekq2 same engine,ones bigger. same care and quality parts nets same performance per cubic inch
01-28-2013 08:03 PM
optimus ok I finally pulled the engine down and here is what i found three lifters had failed in pieces one of them lodged between the cam and block snapping the cam in two places at the back of the second cam bearing and in front of the third cam bearing. that section of the cam was in the oil pan. one of the lifter bores has a deep scratch in it also the #3 and #4 connecting rods show damage from the chunk of camshaft bouncing off of them and hitting the block. so the lost of casualties are lifters, cam, rocker arms, connecting rods, and the block. the heads and pistons are untouched.

I have decided to just go back to what i know and build a small block to replace this failed BB
09-30-2012 03:02 PM
optimus I haven't pulled the pan yet (engine is still in the car) but there is alot of lifter pieces somewhere.
09-30-2012 01:37 PM
vinniekq2 Ive had 1 hydraulic lifter come apart in forever.I wonder if it was damaged when the rocker stud backed out? Sounds like a thourough inspection around cam bearings and lifter bores is in order.If the track is open I personally would throw in a new stick and race unless huge damage is apparent.scope the bearings.

was there a lot of broken metal from the cam that is now in the pan?
09-30-2012 01:03 PM
optimus
not the timing chain

ok so it wasn't the timing chain that broke it was a lifter. it exploded and caused the cam to snap in half I haven't pulled the heads yet so i'm not sure on the extent of the damage but it will definitely be spending the winter on the engine stand being rebuilt...

any ideas on a cause for this?

hydraulic lifters
08-25-2012 11:55 PM
cdminter59
454 race build

I would pull the heads to see if you had valve to piston contact. Check the pushrods by rolling on flat surface. What is the brand and part# of the pistons?What is the Part# of the camshaft? Also do these 115cc chamber heads have casting numbers? If any valves are bent sometimes they will not close all the way. I have used Cloyes Timing chain sets with no problems. Post back of what you find!
08-25-2012 05:20 PM
optimus here is a pic of my car
08-25-2012 05:09 PM
optimus
this isn't good

Ok guys I need some input on this I took it to desert thunder our local 1/8 mile track and made 3 passes not being to hard on the engine because it is fresh. after the third pass my wife and some guys that were watching said it started smoking during the pass. I did some looking and found a wet spark plug #3 cylinder I pulled the valve cover off and found the intake rocker was loose (stud backed out of the head) checked the threads reinstalled set valve lash fired up all was good no smoke. made another pass with a small amount of smoke at the end of the run so i loaded the car up took it home and pulled all the rocker studs thread locked (red) and put it all back together ran perfect.

yesterday 8-24-12 I took the car to caprock motorplex made 1 pass and halfway down the track the engine started backfiring through the carb I could see the flames under the cowl. before I could hit the kill switch the engine DIED.
after i towed the car back to the pit I pulled dist. its fine gear is good looked at gear on cam while cranking and no movement so it looks like the timing chain snapped. this is the chain I have on it Cloyes Gear C-3024X - Cloyes Heavy-Duty Timing Sets - Overview - SummitRacing.com cam is comp cams lift is around 560 intake/exhaust pistons are 39cc dome tops with intake valve relief what are the odds that I can change the timing set and be good to go? Or is it more like slapped / bent valves pushrods = rebuilding this New engine.......

sorry for the long post but information is a good thing most of the time right

James B.
08-08-2012 02:09 PM
WesTex Hot Rods Just read your thread, I'm in Odessa & plan to go out to Caprock this weekend if I don't end up working. What color is your Nova? Good luck by the way.
08-08-2012 11:33 AM
vinniekq2 have fun,,
08-08-2012 09:54 AM
zildjian4life218 Good luck to ya! Bring someone along to take some pics and videos of it going down the track!
08-08-2012 02:32 AM
optimus
it runs

it's been a while sense i have posted anything so i'll update...

I only bored it .30 over so it's actually a 486 but it is up and running.

I went with a TH400 tranny kevlar plates 32 sprag with reverse manual valve body that should handle my HP with no problems and a 2200+- stall..

I'm not sure on what HP it's going to make yet calculators put it at 700.

I'll be at test and tune this friday to try it out.

wish me luck and i'll post my et later
02-29-2012 12:27 AM
optimus well i haven't bought the cam yet that's just what I'm looking at...

however with a 4.25'' stroke crank and 6.385'' rods and 115cc heads and these pistons http://www.jegs.com/i/KB-Performance...7.030/10002/-1 my compression should be around 9.9-1 +/- not sure yet how much the machine shop will have to remove to deck the block but I was thinking and correct me if I'm wrong but with the dome top piston and the longer stroke if I run the bigger lift cam, I run more risk of slapping a valve with a piston. I might be wrong but I was asking for advice on the cam because there are alot of people on here that know alot more than I do. and I would much rather do it right the first time... That said I am open to suggestions and do need to order my pistons quickly so I can get them to the machine shop before they do the final hone on the block so if i should need bigger or smaller pistons I need input by Friday morning..

thanks James
02-27-2012 01:18 AM
327NUT No offense but you need to slow down and discuss your build with a performance engine builder. You don't want to buy a cam before you know what your compression will be.
02-27-2012 12:32 AM
optimus
change of plans

well the deal fell through on the blower so i have decided to stroke it to 496 already ordered a scat crank 4.25 stoke and some forged H beam 6.385 rods what compression ratio would you recommend with 115cc heads? same heads as in the link in post above. I am changing the cam setup also this one I believe will work well with the setup. http://www.jegs.com/i/Comp-Cams/249/CL11-600-4/10002/-1 with 3/8 push rods and 1.7 ratio roller rockers to top it off. any other things i need to look into or change?

thanks in advance
James
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.