Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Turn Signal Lights
User Name
Password
lost password?   |   register now

Thread: Turn Signal Lights Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-06-2013 10:44 PM
72Chevy_Shane yea me to lol thanks for all that info for later on in case it aint a bulb so I know where to look
02-06-2013 04:11 PM
EOD Guy Good to hear it was an easy fix
02-06-2013 08:43 AM
72Chevy_Shane I got it figured out...there was a bulb that didnt look like it shot but it was put a new one in and everything worked fine
02-05-2013 06:20 PM
EOD Guy If the flashers don't work either, I'd start with, as memtioned, cleaning all the sockets, then make sure they have a good ground, then use a test light on the contact inside the socket to see if you're getting juice. If no juice at the socket, then inspect the wires to see if they are broken or frayed, then move to the column electrical connector to see if it's buggered up
02-05-2013 03:30 PM
Pantaz I had a similar problem with a '93 Caprice. I did all the usual troubleshooting, but everything checked out.

You know how they wipe dielectric grease on the bulb bases to prevent corrosion? Well, there was PLENTY of grease in the sockets, but it had become semi-hard and was preventing the bulb from seating fully against the contacts! (Removing and inserting bulbs would push the gunk around just enough for it to interfere.)

I was able to scrape out much of the crud with a small screwdriver, then about half a can of contact cleaner spray and various swabs to get the rest. Never had another problem with the lights.
02-04-2013 11:26 PM
72Chevy_Shane come to think of it no
02-04-2013 03:41 AM
EOD Guy I'd start with the flasher, should be near the fuse box. Do your 4 way flashers work?
02-03-2013 10:33 PM
72Chevy_Shane
Turn Signal Lights

My Grandmas 1996 Buick Regal Gran Sport when you turn the left signal on it doesnt blink and neither does the lights outside Ive changed all the bulbs and still nothing could it be a wire or a switch in the column...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.