Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior> Rock chips in new paint
User Name
Password
lost password?   |   register now

Thread: Rock chips in new paint Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-22-2013 02:46 PM
69 widetrack Hey Brian...I got the information for you, you do have a local SPI distributor and sent you a PM with the co-ordinates...I'm sure it's going to do what you need and more.

Ray
03-22-2013 02:33 PM
tech69
Quote:
Originally Posted by recnepswilliams View Post
I have a question, I've repainted my car, it's a first paint job for me and after driving it just a couple times I've noticed some rusting rock chips around the wheel wells. It's a single stage paint from oreilly auto parts, they tell me it's duplicolor paint, but it's their house brand. I was wondering if this is normal for single stage paint and if I should possibly go with base coat clear coat next time or if it was most likely a problem in preparation? Any ideas? Thanks in advance.
sounds like it was either painted with flash rust under or it could just be the paint. I'm imagining that paint isn't a great barrier to keep moisture out. It's like trying to fill a paper bag full of water. Clear coats are inherently more solid and provide a much better barrier between your metal and the atmosphere.
03-22-2013 02:31 PM
tech69 I have a question about the SPI epoxy...does it shrink and bunch up after the car is sprayed. I was taught to be kind of light on the epoxy due to that but would love to get an epoxy I can use a sealer that won't bunch up and shrink too much. No need for any answers about flash time and application. I already know. Just would like opinions on epoxies that shrink less than others. Any opinions on this?
03-22-2013 12:56 PM
69 widetrack Brian...I won't argue with you that the web site is somewhat difficult to navigate...I just tried to go on the site and find the phone number for their jobber in the San Fran area...I think I've seen one before but, today, I couldn't find it. Send Barry A PM, he's great, and always gets back to you in a decent amount time.

You won't regret using this product Brian, it sprays beautifully, and with the way I abused it (I wouldn't abuse paint on any vehicle the way I abused it on the test panels) on test panels and after several months, what should have shown signs of rust, showed nothing, what should have fallen off by giving it a a dirty look hung on like s#@t on a blanket, an epoxy that sands better than many high end 2K primers, what shouldn't have covered real coarse grinding marks covered, and blocked out...and to this day hasn't sunk, after I prepped and painted the panel. It's only been 2 months but, I should have seen something, anything by now. I know I would have with the products I've used in the past.

I'm not the easiest guy to convert, my feeling always has been if it's working, don't change it. However, I also try and keep an open mind...sometimes what is working can be improved upon and you never know if you don't try it. I'm glad I did.

Ray
03-22-2013 11:46 AM
MARTINSR Ok Ray, you sold me, I am thinking I will probably get SPI epoxy for me truck. So I go to the web site and can't find a friggin thing! The "Products" button gives me a whole list of tech info and pricing and everything under the sun BUT an actual list of products! So far, not very user friendly.

Brian
03-22-2013 11:19 AM
69 widetrack X2 on that Mike...as some of you may know I recently tried SPI for the first time and abused it to no end on my test panels. It's been several months now and on one of the overly abused panels I took a ball peen hammer to the epoxy side and the un- primed side....I beat the crap out of the panel, I couldn't get the primer to let go until I used the flat side of the hammer and hit the primer the flat side of the hammer at an angle. What let go didn't go down to bare metal...so, as Mike said, just because it's epoxy doesn't mean that it's going to give you the protection that the manufacturer claims, chose an Epoxy with a proven record and if SPI can withstand the abuse it took during application and stood up to more abuse than any rocks on the road could give it, guess what I'm using

Ray.
03-22-2013 06:48 AM
deadbodyman I was talking to a friend that used the Sumit kit and has the same problem but he striped the car and used the sumit epoxy so just because you use epoxy dosent mean you get good epoxy ,Go with the SPI.
03-17-2013 11:45 AM
69 widetrack
Quote:
Originally Posted by deadbodyman View Post
It'll be a lot of work but you'll have to strip it to the metal...Your problem isnt so much with the cheap paint but with the primer since the chips go all the way down to the metal...
If you want it nice and want it to last I would strip it and use an epoxy primer over the metal....take the time to order some insted of this parts store crap...epoxy primers arent all the same either SPI epoxy is the most chip resistant ,user friendly epoxy I've ever used and I've been using it exclusivly for well over five years...however using it over your old paint and primer wont help, the car has to be stripped to the bare metal....
Good call Mike....if you've got rust in the rock chipped area the chips are not only taking off the paint you recently applied, it's taking off the paint underneath and going to the bare metal. The only remedy as Mike mentioned is to strip the car. I would also recommend SPI Epoxy as a substrate before applying any color coat. SPI is user friendly, cost effective and affords great rust protection.

The old adage, "you get what you pay for", does apply here as well, buying your paint from the unprofessional at the same place you buy your spark plugs is like getting tune up advice from your grocer. Spend the time to find a paint jobber that can guide you in the right direction. It may cost a little more but, how much money did you save by buying the paint that's chipping off your car now.

Ray
03-17-2013 09:29 AM
deadbodyman It'll be a lot of work but you'll have to strip it to the metal...Your problem isnt so much with the cheap paint but with the primer since the chips go all the way down to the metal...
If you want it nice and want it to last I would strip it and use an epoxy primer over the metal....take the time to order some insted of this parts store crap...epoxy primers arent all the same either SPI epoxy is the most chip resistant ,user friendly epoxy I've ever used and I've been using it exclusivly for well over five years...however using it over your old paint and primer wont help, the car has to be stripped to the bare metal....
03-16-2013 07:36 PM
recnepswilliams That's what I thought I remember hearing somewhere. So my nex question then is, if i paint my daily driver, would their base coat clear cow paint be more durable? And how would I be able to tell how durable the paint is before hand?
03-16-2013 03:08 PM
MARTINSR What you have is lacquer paint, it is the most least durable paint there is. Also, the prep could make all the difference in the world. If you used their primer as well, it's lacquer too I believe so this isn't the best stuff to work with.

Brian
03-16-2013 02:36 PM
recnepswilliams
Rock chips in new paint

I have a question, I've repainted my car, it's a first paint job for me and after driving it just a couple times I've noticed some rusting rock chips around the wheel wells. It's a single stage paint from oreilly auto parts, they tell me it's duplicolor paint, but it's their house brand. I was wondering if this is normal for single stage paint and if I should possibly go with base coat clear coat next time or if it was most likely a problem in preparation? Any ideas? Thanks in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.