Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> Turbo 400 shifting weird
User Name
Password
lost password?   |   register now

Thread: Turbo 400 shifting weird Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-07-2013 10:07 PM
ryan v well I don't think my engine will pull that much vacuum. so i'm just gonna have to live with it unless I put a manual valve body in it?
04-05-2013 11:06 AM
rick 427 Adjustable modulator or not,you need a min. of 17-18 in. of vacuum at the modulator in order for that trans to shift right.
04-04-2013 10:10 PM
zardiw
Quote:
Originally Posted by ryan v View Post
that's what I was thinking might be the problem. do they make an adjustable modulator?

Yup.............z
04-03-2013 08:03 PM
ryan v that's what I was thinking might be the problem. do they make an adjustable modulator?
04-03-2013 07:16 PM
vinniekq2 check vacuum source and modulator
04-03-2013 07:05 PM
ryan v its seems like it has to rev up more than it should to shift
04-03-2013 09:49 AM
vinniekq2 describe weird?
04-02-2013 09:02 PM
ryan v
Turbo 400 shifting weird

I've got a 87 chevy 4x4 with a mild small block in it. Ever since I put this engine in my transmission has shifted weird. Would the lower vacuum pull of this motor cause this problem? It was a tbi motor but I swapped it to a carbed setup.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.