Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> power steering rsevoir hot!
User Name
Password
lost password?   |   register now

Thread: power steering rsevoir hot! Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-20-2013 01:26 PM
techinspector1 I think I'd call Flaming River and ask them what the temp should be, then measure it with an IR gun. If it exceeds their recommendation, rig up a cooler.
04-20-2013 09:20 AM
rs7337
power steering rsevoir hot!

I have a 68 mustang powered by a 2.3 turbo ford engine. I am using a flaming river power rack setup for steering. the rack tho is actually from a 97 monte carlo, as best i can tell. the pump is from a 96 taurus. The steering works and all but the resevoir is getting hot. almost too hot to touch.
I researched the pumps from both the monte carlo and the taurus, and they are almost identical. i researched the pulley diameter from each car and compared them to mine. slight differecnes but not enough to make a huge change i wouldn't think.
maybe someone here has more insight on this. or maybe the internals of the 2 pumps are different.
Just wanting some thoughts on this.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.