Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> Timing light/plug lead Problem
User Name
Password
lost password?   |   register now

Thread: Timing light/plug lead Problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-25-2013 11:53 PM
dave350v8 Cheers mate, will have a look at weekend didnt realise there was an arrow!
If it is worn out can I use another off an old timing light even though its not a snap on?
04-25-2013 05:45 AM
Richiehd Dave, could be wore out. If there is an arrow on the induction clip, make sure it is pointing to the plug. Make sure you have good ground, and move clip away from any other wires, if possible.
04-24-2013 11:20 PM
dave350v8
Timing light/plug lead Problem

Hi Everyone,
When I use my snap on dial back timing light, the light does not always flash,
could this be a plug lead fault? Or am I right thinking the "inductive clip" that
I put on the plug lead could be faulty?

I read somewhere that it is suppose to miss every other flash?


Cheers dave

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.