Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 4-speed in and running!
User Name
Password
lost password?   |   register now

Thread: 4-speed in and running! Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-07-2013 09:56 AM
31ROC just wasnt sure if hydraulic clutches were different in adjustments than conventional.....prob gonna extend the threaded rod on linkage to get pedal at higher start point.....wonder if the "travel" will be too long then and hurt master?
05-07-2013 08:10 AM
vinniekq2 sounds like it could move higher for your comfort.Its your car,where do "you" want enguagement?
05-07-2013 06:42 AM
31ROC
4-speed in and running!

This past winters project near completion...(transferred 700r4 to Muncie 4 speed). Car runs and shifts, but definitely needs clutch pedal adjustment. Since this is my first hydraulic T/O bearing, where should the clutch start engaging? How far should the pedal go down?
These are the under floor pedals, and I feel I may have the clutch pedal set to low to start, as I push it down, it gets real "flat" on me. Meaning--- when I push the clutch pedal down its starts at about 45* angle to the floor, and will go down to almost flat with the floor making it quite uncomfortable to the leg and foot. Maybe I need to lengthen the adjustable rod in the master to be longer, moving the pedal starting point towards the seat more?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.