Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> 55 Chrysler 300
User Name
Password
lost password?   |   register now

Thread: 55 Chrysler 300 Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-10-2013 08:58 AM
tech69
55 Chrysler 300

still sitting about to go get interior done. too bad it leaves here before the chrome is put back on. I did most of the work on this car.




This gas door was interesting. Had to fabricate the little lump.



To be able to do these cars efficiently you have to be your worst critic and see only the imperfections. On this one right below the sail panel I see an imperfection. Something that may have slipped into the primer rounds but a good tech will find everything before that second app of primer. The rule of thumb for me is if it's an area where guide coat won't show me squat then I hand feel it. What I think happened here, and I don't want to make any excuses, is that someone used a 10" block on that area. I blocked the other side and I wouldn't use the standard 10" dura block, I would have used the skinnier one with more flex for that spot. The other side doesn't have that wave. when I made my usual round of checking over someone's blocking I found a few things and addressed them, but I didn't find this. Nothing to botch about though cause it's an even trade cause he knows a lot more than me.


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.