Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> HELP!!!!! Moaning / Groaning Front Suspension??????
User Name
Password
lost password?   |   register now

Thread: HELP!!!!! Moaning / Groaning Front Suspension?????? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-11-2013 05:24 PM
enjenjo Lube the Poly bushings, they are famous for this.
05-11-2013 04:18 PM
texastomeh
HELP!!!!! Moaning / Groaning Front Suspension??????

Have just finished(?) rebuilding most (new HD Sway Bar, New Poly Bushings, New Idler Arm Bushing, Shocks, Coil Spring Isolators, etc.) of my '63 T'Bird HT's front suspension. The Ball Joints and all of Tie Rod linkage and ends had been replaced by PO and were good and tight - so just replaced some torn boots and lubed good. Power Steering fluid was flushed and bled, and filter replaced. Works perfectly. All belts are nice and snug. Also did a "start-from-square-one" alignment.

Results? She rides and handles like a dream!! Only problem is that ocassionally when I am make a slow speed turn (eg; into driveway, at a stoplight or a corner in city driving) I hear a low level "Groan" / "Moan" (NOT a "squeal") from the fontend. Doesn't matter whether I am turning RIGHT or LEFT (although it does seem to be more prevalent during LEFT turns).

I can't seem to isolate it and, as expected, It doesnt occur when sitting in the diveway or garage with the hood up!

ANY help and/or suggestions would be GREATLY appreciated!!

TOM

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.