Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> have a look, can this be fixed?
User Name
Password
lost password?   |   register now

Thread: have a look, can this be fixed? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-07-2004 10:07 AM
mikeweyman thanks guys, i'll find out soon.
02-06-2004 12:27 PM
willys36@aol.com Looks like it is just the one open circuit. Impossible to tell if any of the components is fried too. Easy to test, just solder on a jumper wire and try it. If it works, great and you save spending the national debt @ Chevy for a replacement, if not nothing lost except a month's income to GM!
02-06-2004 12:24 PM
mikeweyman hheres the back
02-06-2004 12:19 PM
mikeweyman it runs the tachometer on my 75 stingray,it's located inside the tach itself.by what i hear it just happens,no reason, but it is the cause of 98%of all these tach failures. this is the only one i've seen that wasn't totally fried.
I've posted both front and back views if they're any help.
02-06-2004 10:21 AM
302 Z28 Sure it can be repaired, just solder a wire from either sides of the burnt portion on good copper. Now as to finding what caused it, that is anyones guess. Not knowing what exactly that circuit does and not having a circuit diagram, well it's a toss up.

Vince
02-06-2004 05:19 AM
mikeweyman
have a look, can this be fixed?

this is the tach circuit from my 75 stingray, can this be repaired?will it likely happen again?what would cause this?any input would be greatly appreciated. mike

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.