Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 600 holley carb pops on acceleration
User Name
Password
lost password?   |   register now

Thread: 600 holley carb pops on acceleration Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-28-2004 06:47 PM
lluciano77 It sounds to me like you have either too much or too little jet. Find out the Holley recommended jet size and use those. You can go up or down no more than 4 jet sizes.

If that doesn't work, you have clogged air bleeds. Clean them. They are the small holes in the air horn.
02-28-2004 06:38 PM
BOBCRMAN@aol.com Is the accelerator pump arm set correctly? is the pump cam in good shape? are the squirters open and spraying? Is the power valve correct for your application?
02-28-2004 05:42 PM
bt101
600 holley carb pops on acceleration

Hi, I have a 68 camaro, automatic, with a brand new 356 chevy. A cam with 410 lift and and torker intake. I have a 600 holley carb with a brand new power valve. The car runs very well. Valves set and the timeing advanced to specs. Only upon VERY HARD acceleration does the poping happen out the carb. We also have headers and open mufflers.
The idles screws work properly, and thr floats set correctly.
Any advice?

Thanks in advance

Bill

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.