Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> lack of horses
User Name
Password
lost password?   |   register now

Thread: lack of horses Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-07-2004 08:25 PM
74CHEVY Yes it's a Holly. It's a 2BBL on a 4BBL manifold. The distributor has been completely rebuilt. The EGR valve is gone. New timing chain and sprocket. Timing is dead on at 8 degree. Using an abundant amount of gas. Occasionally backfires through the carburetor. This is a stock 32K V coil, would it help to go to a higher voltage coil, possibly not enough spark?
03-05-2004 01:00 PM
Dubz carb and or timing

did you get rid of the EGR when you got your new manifold?
may need to re-curve your distributor

why are you jumping all over the "how do you know he has a holley" stuff people? this is supposed to be a friendly board
03-05-2004 11:44 AM
funk master flex how do you know holly
03-04-2004 11:24 PM
4 Jaw Chuck Sounds like the thing needs some TLC and an overhaul...start with the carb.
03-04-2004 08:39 PM
BstMech
Quote:
Originally posted by FASTCHEVY
Power valve? how do you know he has a Holly?
Who said anything about it being a Holley?
03-04-2004 08:15 PM
FASTCHEVY Could be a timing prob.

What have you replaced on the truck?


Power valve? how do you know he has a Holly?

We need more info.
03-04-2004 08:12 PM
lluciano77 It sounds like your accelerator pump shot is weak. Give it more gas on the accelerator shot.

You may need a different power valve as well. When you add a performance cam your vacuum changes, and so does the powervalve opening requirement.
03-04-2004 08:08 PM
74CHEVY
lack of horses

I have a 74 chevy 1/2 ton w/350 4bolt. This is the original motor, when Igot the truck the cam was completly rounded. I have changed the cam,intake manifold,carb,&dist.This motor came with a 2bbl and this what was replced with. When you go to take off the motor tries to cut out but if u feather the gas pedal it comes back around but with serious lack of power. I know this motor is strong a friend has same setup and running fine. PLEASE HELP!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.