Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> 1965 Impala Front End Suspension Problem
User Name
Password
lost password?   |   register now

Thread: 1965 Impala Front End Suspension Problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-29-2004 05:52 PM
adtkart Like Jim said. Heating the springs is the wrong way to go about it. Heating the springs will make them just coils of round steel. The heat will take the spring out of them.
03-29-2004 12:21 AM
jimfulco Heat can mess up the springs. I bought some Nova springs (same part # as the old ones) from GM a few years ago & they sent big-block springs (for a small-block car). Said the part # was superceded. Yep it sat too high. The local spring shop torched them & got it down to the right height. Within a few months, they had sagged & dropped it down another 1-1/2" or so. Did the shop that did the work order the springs? If so, they should fix it and not charge you.
03-28-2004 09:26 PM
EazyDuzIt102
1965 Impala Front End Suspension Problem

Hey everyone.Ok here is what happened.I bought my 65 Impala about 2 years ago.When I got it,I noticed that the front end was sitting really low to the ground.It was way lower than the stock height.The shocks were trashed and the springs were really weak.So I went and ordered new springs for the front end.I have a 327 Small Block in my Impala.When I ordered the new springs,they asked me what size engine I had.So I told him I had a 327 Small Block.They ordered the wrong springs and ended up selling me the BIG block springs.So I had the new springs put in and now my front end is sitting WAY TOO HIGH.The springs are so strong because they are made for a Big Block engine.So I dont wanna bring the car back in and pay another 250$ to get them to take out these springs and put in small block springs.So my question is,Can I heat up the springs that I got in the Impala right now?I talked to a couple of guys allready and they said I could Heat Up The Springs and that will weaken them and that should drop the front end back down.I cant get the wheels aligned now because the Suspension is maxed out and there is no room to put shims.Thanks,

Eazy

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.