Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 700R4 with slipping converter clutch
User Name
Password
lost password?   |   register now

Thread: 700R4 with slipping converter clutch Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-28-2004 05:56 AM
M&M CUSTOM ttt
08-20-2004 06:39 AM
CleviteKid
700R4 with slipping converter clutch

My 700R4 is circa 1988, but recently rebuilt with new lock-up converter.

Recently, when warm (not hot) the clutch slips while locked up in 4th gear. Going up a long hill with cruise control, speed is rock solid steady, but RPM goes up 100 to 200, but clutch is partially locked because if I turn off TCC solenoid with dashboard switch, RPM goes up another 100 to 200, depending on steepness of hill.

Voltmeter across A and D terminals at tranny shows full voltage, even as TCC is slipping. Other than a glazed clutch, what else might be causing this?

By the way there is no shudder or jerking, just very smooth increase in RPM (and its real, I can hear the exhaust pitch rise, also).

Thanx for any help,

The Clevite Kid

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.