Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Electric Fan
User Name
Password
lost password?   |   register now

Thread: Electric Fan Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-29-2004 11:49 PM
julmer In-line fuses are not necessairly evil but have to be the right kind and rated for the load - motor starting, in this case. A fan that pulls 10 amps is going to need at least a 20 amp slow blow fuse to survive. Your generic SAE20 likely won't cut it for that application.
BTW, fusable link in that application really is a pretty good idea.
09-28-2004 01:52 AM
horvath In line fuses blow like crazy on a 16-inch fan ... I use a fusible link and double relays on mine and it works sweet as can be; no heavy power draw, like when I had a circuit breaker on it, and no fuses blowing, like when I tried an in-line fuse!

Here's My Whole Take On the Subject - Click Here

And if you aren't educated about fusible links, Read This!

Alan
54 Chevy Pickup
09-27-2004 03:14 PM
docvette
Relay

[size=3]Doc here:

Get a Double pole single throw relay, and a Proper in-line fuse for the fan, and a proper Single thow/pole Toggle or rocker switch.

Hook one side of the relay COIL to 12 volts power Through any 1 to 5 amp fuse , The other side of the COIL to the wire going to your Fan on/off switch.

From the On/Off switch, hook the other wire to ground. (Your Switching grounds)

The Center wiper of your Relay (Movable Contact ) Will go to your Fan Motor, the other side of the motor to ground.

The "Normally Open" Side of the contact will go to a proper size fuse, then to power..

If your Kit came with a Thermostat Sender, you can now wire that so the lead goes to the Fan switch where the relay Coil wire comes in, and it will run in "Automatic" when the switch is in the "OFF" position...from the signal from the sender. (Remember: the Control circuit (Relay switch)is switching ground, not power, so as the temp rises at the sender, more ground goes toward the switch...turning the fan on automatically.)

You can also use a lighted switch, or an indicator lamp If you wish the option, It's good to know if the Fan is actually running! Just hook it to your Movable Contact on the relay, the other side to ground.

Hope I Didn't Confuse you...

Doc
[/size]
09-27-2004 10:28 AM
Dave E Shank HEY JOHN: I have an electric booster fan mounted in front of my radiator. I have it on a lighted on off switch that I bouught at Auto Zone for a couple of bucks. I wired it in series with line going to fan motor. At one time I had a 16 inch puller electric fan and I had it wired with dash board swich but went thru a relay because of higher current pull. Relay are about ten bucks and come with wiring diagram. Don't worry your mom could do this job....DAVE
09-27-2004 09:47 AM
malibuman66
Electric Fan

Just bought an electric fan for my Chevelle, two wires on it, one goes to battery, other to ground. Want to install a on and off switch to it, can anyone tell me how I can do that ?? Like to mount it under my dash......Thanks

John

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.