Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Electric Cooling Fan Mounting
User Name
Password
lost password?   |   register now

Thread: Electric Cooling Fan Mounting Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-22-2004 12:15 PM
subman17 Yeah, I agree with you Tazz, I didnt like pushing those things through the radiator, but I figured "everyone is doing it right?" Anyways, lesson learned, plastic push through mounts suck.

Subman
10-22-2004 11:05 AM
tm454
I don't like pushing something through the radiator.

So I made a custom bracket to hold the fan and mounted it to the radiator shell mount itself and not on the radiator. I never heard of one leaking but I suspected one might and don't want to take that chance myself so thanks for confirming my suspicions!!!


Tazz


Rat Rods Rule!
10-22-2004 10:43 AM
subman17
Electric Cooling Fan Mounting

Hello all, Don't know if this is the right place for this, but here it goes.

I have a 1969 Chevy C-10 pickup with a SB350. I added a Weiand 144 supercharger a couple of months ago, and it wasn't staying cool in traffic with the mechanical fan and my 4 core radiator. Well, I switched to an electric fan and it fixed the cooling issues, and has been fine for about a month. Yesterday I am driving to the local car show, and I can smell coolant, so I stop and my radiator is leaking right in the middle of the core where one of those stupid plastic fan mounting things goes through the radiator. So, a new radiator is coming today, and I don't want the same problem again, so am I better off mounting my fan on custom brackets? Should I also move my trans cooler off to the radiator?(It uses the same plastic push through mounts) Has anyone else had this problem? Thanks!

Subman

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.