Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> LOUD POP! noise when turning right in S-10
User Name
Password
lost password?   |   register now

Thread: LOUD POP! noise when turning right in S-10 Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-12-2005 08:31 PM
cknox88 im not sure what your talking about that self adjuster sleeve explain that to me better if you would. The sound is coming from the drivers side front wheel area.
01-12-2005 10:47 AM
Stinkin_V8 Maybe a torsion bar mount? They're a chronic problem on the 4WD S-10 but usually make more of a clunk than a pop.

The only other thing I can think of is maybe a sway bar mount up front..

Where is the sound coming from? Up front, or under your feet?
01-12-2005 10:42 AM
68NovaSS Did you replace or at least ensure the old "O" rings were in place where the self adjuster sleeve passes through the caliper body?
01-11-2005 07:51 PM
cknox88
LOUD POP! noise when turning right in S-10

ok heres the deali have a 91 s-10 4wd. ok so the other day my brake caliper froze up about a half mile from home. i stopped hit the caliper a couple times with a hammer and the piston went back in a little. os i drove it home tore it down got the parts fixed it and now when turning right if i hit a bump while in the turn it pops real loud. its acually missing a stud on that wheel that im going to replace tomarrow but that cant be whats causing it because its been like that for about 3 weeks. so if anyone knows what this possibly is plaese reply.

Thank You

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.